Link to home
Start Free TrialLog in
Avatar of fm250
fm250Flag for United States of America

asked on

config cisco 877 adsl pppoa

I had a cisco 678 modem that (end-of-sale). I have a replacement for it cisco 877 that I am trying to config but could not get it to work. (the isp is not supporting this router, but I have the needed info).

First here is what I had for 678 modem:
-----------
set ppp wan0-0 dns 0.0.0.0
set ppp restart enabled
set ppp wan0-0 authentication enable
set ppp wan0-0 login user
set ppp wan0-0 password pass
set int eth0 address xxx.xxx.xxx.xxx
set int eth0 netmask 255.255.255.248
write

set dhcp server disabled
write

set int wan0-0 disable
set int wan0-0 vpi 0
set int wan0-0 vci 32
set int wan0-0 enable
set int wan0-0 open
write
reboot
----------------------------
and here is what I have tried for cisco 877
----------------------------
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 0/32
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
dsl operating-mode auto
!
interface Dialer0
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip route-cache flow
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication pap chap callin
ppp chap hostname [user deleted]
ppp chap password [pass deleted]
ppp pap sent-username [user deleted] password [pass deleted]
------------------end-------------

I was trying to do negotiated as it can also work that way with the isp, but I will need to do Unnumbered IP.

Any ideas what is going wrong, thanks!
Avatar of trinak96
trinak96

Can you post your whole cisco config ?
Avatar of fm250

ASKER

here is the whole config:
note shutdown because it is not on now, I have also tried the wizard but did not work. but this is the current config, thanks!
---------------------------------------------

Using 1055 out of 131072 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
 pvc 0/32
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
 dsl operating-mode auto
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!

!
interface Vlan1
 no ip address
!
interface Dialer0
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip route-cache flow
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication pap chap callin
 ppp chap hostname user
 ppp chap password 0 pass
 ppp pap sent-username user password 0 pass
!
ip classless
!
no ip http server
no ip http secure-server

!
control-plane
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
!
scheduler max-task-time 5000
end
fm250,
Add the following

Router(config)# dialer-list 1 protocol ip permit
Router(config)# ip route 0.0.0.0 0.0.0.0 dialer 0

Then enbale atm interface.
Post a "show dsl int atm0"
You should be ok from an external point of view and be able to ping web sites from the dialer interface.
Next you will have to set up the internal interface addressing and NAT in order to use it from pc's on the network.
Avatar of fm250

ASKER

Trinak:
here is the new config, can you look at it and see if this what I need. Alos is vlan1 goup all eth 0, 1,2,3 ?  thanks!
------------------------------------------
Using 1267 out of 131072 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
no ip dhcp use vrf connected
!
ip dhcp pool sdm-pool1
   import all
   network 192.168.6.0 255.255.255.0
   default-router 192.168.6.1
!
!

!
!
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 0/32
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
 dsl operating-mode auto
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
 ip address 192.168.6.1 255.255.255.0
!
interface Dialer0
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip route-cache flow
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication pap chap callin
 ppp chap hostname user
 ppp chap password 0 pass
 ppp pap sent-username user password 0 pass
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip http server
no ip http secure-server
!
dialer-list 1 protocol ip permit
!
control-plane
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
!
scheduler max-task-time 5000
end
-------------------------
Avatar of fm250

ASKER

Also that did not work! any suggestions? thanks
Avatar of fm250

ASKER

Also here is the: show dsl interface atm0
-------------------
ATM0
Alcatel 20190 chipset information
Line has not yet been activated.  No information available.

DSL: Training log buffer capability is not enabled
fm250

You dont have an active adsl line, as in your last post "Line has not yet been activated"
Check your cabling & ISP has actually provided adsl to the line number your using.

Avatar of fm250

ASKER

I works fine from another 2wire adsl modem, but not from this cisco!
Avatar of fm250

ASKER

I ment "it works" the same line.
fm250,

Add "dsl operating-mode auto" into atm0 config. Make sure adsl line is connected and do a "sh dsl int atm0" again.
Avatar of fm250

ASKER

I have added it again even though it is there in the config (see above) with same result, no connection.  any other ideas!
What IOS version are you running? I cant think of anything else, apart from a dodgy ATM interface. Could you try on a differnet adsl connection, another known working one, to be sure ?
How long have you had the 877, is it a new purchase or existing stock?

Avatar of fm250

ASKER

this is cisco 877 new purchase.
----
Cisco IOS Software, C870 Software (C870-ADVSECURITYK9-M), Version 12.4(4)T7
----
fm250,

This link fro cisco site : http://www.cisco.com/en/US/products/hw/routers/ps380/products_configuration_guide_chapter09186a008045d284.html#wp1044982

Details on debugging the ATM interface, you can the pvc values as well as their output.
Otherwise I would return it.
can you post a "sh ver" as well please ?
SOLUTION
Avatar of Elwin3
Elwin3
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of fm250

ASKER

I have tried the firmware ver 2.6.4 with this ios 12.4.
Also I have a set of IPs where I should config the router to Unnumbered Mode gateway ip then subnet mask, how do I configure that.

Also here is the sh ver:
--------------------------------------------------------------------------------
Cisco IOS Software, C870 Software (C870-ADVSECURITYK9-M), Version 12.4(4)T7, REL
EASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2006 by Cisco Systems, Inc.
Compiled Wed 29-Nov-06 00:43 by kellythw

ROM: System Bootstrap, Version 12.3(8r)YI4, RELEASE SOFTWARE

Router uptime is 1 hour, 10 minutes
System returned to ROM by reload
System image file is "flash:c870-advsecurityk9-mz.124-4.T7.bin"
Last reload reason: Reload Command
----------------------------------------------------------------------------------
Avatar of fm250

ASKER

Also here is some info on debug commends if somebody have any clue: thanks
-----
sh dsl int atm0
ATM0
Alcatel 20190 chipset information
Line has not yet been activated.  No information available.

DSL: Training log buffer capability is not enabled
----------------------------------------------------
show interface atm 0
ATM0 is down, line protocol is down
  Hardware is MPC ATMSAR (with Alcatel ADSL Module)
  MTU 4470 bytes, sub MTU 4470, BW 4608 Kbit, DLY 80 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ATM, loopback not set
  Encapsulation(s): AAL5  AAL2, PVC mode
  10 maximum active VCs, 1024 VCs per VP, 0 current VCCs
  VC Auto Creation Disabled.
  VC idle disconnect time: 300 seconds
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: Per VC Queueing
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 output buffer failures, 0 output buffers swapped out

----------------------
show atm interface atm 0
Interface ATM0:
AAL enabled:  AAL5   AAL2, Maximum VCs: 10, Current VCCs: 0

VCIs per VPI: 1024,
Max. Datagram Size: 4528
PLIM Type: ADSL - 4608Kbps Upstream, DMT, TX clocking: LINE
0 input, 15 output, 0 IN fast, 0 OUT fast
 Avail bw = 4608
New Config. not yet ACTIVE


----------------------
show interface dialer 0
Dialer0 is up (spoofing), line protocol is up (spoofing)
  Hardware is Unknown
  Internet address will be negotiated using IPCP
  MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 1 seconds on reset
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 00:43:27
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 42 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes
     0 packets output, 0 bytes

------------------
Router#show interface dialer 0
fastethernet 0
FastEthernet0 is up, line protocol is down
  Hardware is Fast Ethernet, address is 001c.b07b.14b0 (bia 001c.b07b.14b0)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Auto-duplex, Auto-speed
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
 -----------------------
fm250,

Can you post the debugs from the cisco document i posted above, this could help if it's a config problem. Can you post any relevant info from the 2wire router setup ?
Avatar of fm250

ASKER

the 2wire is set to unmubered mode where I have put the ip + gateway addresses. and the user name and the pass for pppoa. there is the whole config above for an old cisco 678 that was working with this same dsl line.

here is the debug command output:
-----------------
*Aug 23 07:27:45.182: DSL(ATM0): 10: Modem state = 0x8
*Aug 23 07:27:47.682: DSL(ATM0): 11: Modem state = 0x8
*Aug 23 07:27:50.182: DSL(ATM0): 12: Modem state = 0x8
*Aug 23 07:27:52.682: DSL(ATM0): 13: Modem state = 0x8
*Aug 23 07:27:55.182: DSL(ATM0): 14: Modem state = 0x8
*Aug 23 07:27:57.682: DSL(ATM0): 15: Modem state = 0x8
*Aug 23 07:28:00.182: DSL(ATM0): 16: Modem state = 0x8
*Aug 23 07:28:02.682: DSL(ATM0): 17: Modem state = 0x8

..... same output
ASKER CERTIFIED SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of fm250

ASKER

The phone line of the dsl should connect directly to this router, correct?

Also:
When reloading the modem it seems it tries to connect, can you look to this result.

*Aug 23 15:43:20.531: DSL(ATM0): 5: Modem state = 0x10
*Aug 23 15:43:21.679: DSL: Received response: 0x22
*Aug 23 15:43:21.679: DSL: Open failed: None -- retrying
*Aug 23 15:43:21.679: sleep 5 seconds
*Aug 23 15:43:26.679: DSL: Send ADSL_OPEN command.
*Aug 23 15:43:26.679: DSL(ATM0): Using subfunction 0x0
*Aug 23 15:43:26.679: LOCAL:Max noise margin for power cutoff 31
*Aug 23 15:43:26.679: DSL(ATM0): Sent extended command 0x3
*Aug 23 15:43:29.179: DSL(ATM0): 1: Modem state = 0x8
*Aug 23 15:43:31.679: DSL(ATM0): 2: Modem state = 0x8
*Aug 23 15:43:34.179: DSL(ATM0): 3: Modem state = 0x8
Yes, adsl should be connected directly to adsl interface on the back - double check the connection. The software is trying to do its bit but there just isnt anything for it to connect to. Either connection is bad, interface damaged or a manufacturing fault.
Avatar of fm250

ASKER

manufacturing fault, thank you trinak
fm250,

Happy to have been of help, all the best.....