Link to home
Start Free TrialLog in
Avatar of aseisman
aseisman

asked on

External Telnet Cisco 2811 Router

How can I enable external telnet access to my router? I am able to access it using its internal IP but not from outside the network.
Avatar of Istvan Kalmar
Istvan Kalmar
Flag of Hungary image

Please show the whole config and I put the commands that you need
Avatar of aseisman
aseisman

ASKER

Here is the config
yourname#show RUN     
Building configuration...

Current configuration : 6236 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname yourname
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
aaa new-model
!
!
aaa authentication login userauthen local
aaa authorization network groupauthor local 
!
!
aaa session-id common
dot11 syslog
!
!
ip cef
no ip dhcp use vrf connected
!
ip dhcp pool LAN
   import all
   network 10.0.1.0 255.255.255.0
   default-router 10.0.1.1 
   dns-server 4.2.2.1 4.2.2.2 
   lease infinite
!
!
ip domain name yourdomain.com
!
multilink bundle-name authenticated
!
!
crypto pki trustpoint TP-self-signed-3579361095
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3579361095
 revocation-check none
 rsakeypair TP-self-signed-3579361095
!
!
crypto pki certificate chain TP-self-signed-3579361095
 certificate self-signed 01
  3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030 
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274 
  69666963 6174652D 33353739 33363130 3935301E 170D3039 30373234 31383238 
  35335A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649 
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 35373933 
  36313039 3530819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281 
  8100B4D4 BE8AFDC2 BD85F413 5F195E04 12765448 B54D2EC4 B9FCE684 6E76C730 
  DF0ACE7A 9E64A5CE 820638C5 3867C494 5783B5A7 44DAB643 73CAE524 A19DC4EB 
  E881D7F4 88E838F7 AA1AA8E0 1FDBBD70 124FD296 AA087A96 4AB2B925 E51F6961 
  37C8E89D 4B3B1FD2 AAD11B2D EB0A1708 368265B2 3EBCF88A E00B349E D4B32FE1 
  5F390203 010001A3 77307530 0F060355 1D130101 FF040530 030101FF 30220603 
  551D1104 1B301982 17796F75 726E616D 652E796F 7572646F 6D61696E 2E636F6D 
  301F0603 551D2304 18301680 145DAA56 8BE4F9C9 CCE4C686 35F858D1 288E158D 
  56301D06 03551D0E 04160414 5DAA568B E4F9C9CC E4C68635 F858D128 8E158D56 
  300D0609 2A864886 F70D0101 04050003 81810009 FC7C05C6 4BA3C656 92E1BED5 
  55F65E3D CE40917B 6276AA35 59C46A93 75D9F723 280521E3 5EB353D0 D4751C49 
  F643FED1 65E2D0E0 8B4FB1DF 0459BD9F C00AB3E4 E7BB1F93 EEC47774 4A7C0245 
  4524AFA2 4138FFF9 A4195C2A CB50397F AF6B94F7 529161AB 08C49D98 0E9DD561 
  6B6AC26F E48F07F3 F2E85B6B 26AEAB22 110784
  	quit
!
!
username USER privilege 15 secret 5 $1$4ApO$cLg18ne2hFW3sHy01yNsE0
username USER password 0 PASSWORD
archive
 log config
  hidekeys
! 
!
crypto isakmp policy 3
 encr 3des
 authentication pre-share
 group 2
!
crypto isakmp client configuration group 3000client
 key pam123
 dns 4.2.2.1
 wins 10.0.1.1
 domain manvantage.com
 pool ippool
 acl 102
 include-local-lan
 netmask 255.255.255.0
!
!
crypto ipsec transform-set myset esp-3des esp-sha-hmac 
!
crypto dynamic-map dynmap 10
 set transform-set myset 
 reverse-route
!
!
crypto map clientmap client authentication list userauthen
crypto map clientmap isakmp authorization list groupauthor
crypto map clientmap client configuration address respond
crypto map clientmap 10 ipsec-isakmp dynamic dynmap 
!
!
!
!
!
!
interface FastEthernet0/0
 description $Cable$
 ip address XX.XX.XX.XXX 255.255.255.248
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat outside
 ip virtual-reassembly
 ip route-cache flow
 duplex auto
 speed auto
 no mop enabled
 crypto map clientmap
!
interface FastEthernet0/1
 ip address 10.0.1.1 255.255.255.0
 no ip redirects
 no ip unreachables
 ip nat inside
 ip virtual-reassembly
 ip route-cache flow
 duplex auto
 speed auto
 no mop enabled
!
ip local pool ippool 10.0.1.160 10.0.1.191
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 96.57.246.169 251
ip route 0.0.0.0 0.0.0.0 96.56.92.137 251
!
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 103 interface FastEthernet0/0 overload
!
access-list 1 permit 10.0.0.0 0.0.15.255
access-list 23 permit 10.10.10.0 0.0.0.7
access-list 23 permit 10.0.1.0 0.0.0.255
access-list 102 permit ip 10.0.1.0 0.0.0.255 any
access-list 103 deny   ip 10.0.1.0 0.0.0.255 10.0.1.0 0.0.0.255
access-list 103 permit ip 10.0.1.0 0.0.0.255 any
!
!
route-map RMAP_1 permit 1
 match ip address 102
 match interface FastEthernet0/0
!
!
!
control-plane
!
banner exec ^C
% Password expiration warning.
-----------------------------------------------------------------------
 
Cisco Router and Security Device Manager (SDM) is installed on this device and 
it provides the default username "cisco" for  one-time use. If you have already 
used the username "cisco" to login to the router and your IOS image supports the 
"one-time" user option, then this username has already expired. You will not be 
able to login to the router with this username after you exit this session.
 
It is strongly suggested that you create a new username with a privilege level 
of 15 using the following command.
 
username <myuser> privilege 15 secret 0 <mypassword>
 
Replace <myuser> and <mypassword> with the username and password you want to 
use.
 
-----------------------------------------------------------------------
^C
banner login ^C
-----------------------------------------------------------------------
Cisco Router and Security Device Manager (SDM) is installed on this device. 
This feature requires the one-time use of the username "cisco" 
with the password "cisco". The default username and password have a privilege level of 15.

Please change these publicly known initial credentials using SDM or the IOS CLI. 
Here are the Cisco IOS commands.

username <myuser>  privilege 15 secret 0 <mypassword>
no username cisco

Replace <myuser> and <mypassword> with the username and password you want to use. 

For more information about SDM please follow the instructions in the QUICK START 
GUIDE for your router or go to http://www.cisco.com/go/sdm 
-----------------------------------------------------------------------
^C
!
line con 0
 transport output telnet
line aux 0
 transport output telnet
line vty 0 4
 access-class 23 in
 privilege level 15
 transport input telnet ssh
line vty 5 15
 access-class 23 in
 privilege level 15
 transport input telnet ssh
!
scheduler allocate 20000 1000
!
end

yourname#  

Open in new window

ASKER CERTIFIED SOLUTION
Avatar of Istvan Kalmar
Istvan Kalmar
Flag of Hungary image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial