Link to home
Start Free TrialLog in
Avatar of B-SON
B-SON

asked on

Configuring a vlan trunk port on Cisco 2960G to connect to a Cisco 6509

I have a Cisco 6509 switch at our core with existing VLans.  I have created a new vlan to connect to a Cisco Catalyst 2960G swicth.  I have everything configured properly on the 6509, but I can not get the trunk port to work correctly on the 2960.  Here the config from the 2960 and the 6509
2960G
!
interface GigabitEthernet0/24
 description Uplink-FW-6509-Gi-8
 switchport access vlan dynamic
 switchport mode trunk
 spanning-tree portfast
!

6509
!
interface GigabitEthernet8/48
 switchport
 switchport access vlan 30
 no ip address
!
interface Vlan30
 description Net_192.168.1.0/24 - Mail Route
 ip address 192.168.1.6 255.255.255.0
 ip helper-address 10.6.25.16
 no ip redirects


On the 6509 when I do a show Vlan it shows the port giga8/48 as active
but on the 2960 it does not show the port gig0/24 as part of the Vlan
Thanks
Avatar of bkepford
bkepford
Flag of United States of America image

You need to connect both switches with either a trunk port or an access port not one on either side. They have to match. For example if you want the 2950 to only belong to the one vlan and not pass multiple vlan traffic you configure like this.

interface GigabitEthernet0/24
 description Uplink-FW-6509-Gi-8
 switchport mode access
 spanning-tree portfast

Or if you want the 2950 to pass the vlan tags and only allow vlan 30 for now you can reconfigure your switches like this

interface GigabitEthernet0/24
 description Uplink-FW-6509-Gi-8
 switchport trunk encapsulation dot1q
 switchport mode trunk
 
interface GigabitEthernet8/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30
 no ip address
You would then need to add any access ports to vlan 30 on the 2950
 
Oh yeah I noticed you are trying to setup portfast on the line between switches. This is not recommended as a configuration as it could cause loops if you accidently plugged in a redundant line.
Avatar of B-SON
B-SON

ASKER

I have tried to add the switchport trunk encapsulation dot1q on the 2960G but it is not an available command.  The version of the IOS :
Cisco IOS Software, C2960 Software (C2960-LANBASE-M), Version 12.2(35)SE5, RELEA
SE SOFTWARE (fc1)
Could the LANBASE-M be the problem? Do we need an IPBASE IOS?  Can you install an IPBASE IOS on a 2960G Switch?
Thanks
Not sure but it is strictly a switching command did you remove the switchport mode access first?
Avatar of B-SON

ASKER

Here is the new config on the 2960G:
!
interface GigabitEthernet0/24
 description Uplink-FW-6509-Gi-8
 switchport mode trunk
!
when i try to configure switchport trunk encapsulation dot1q  i get invalid input at encapsulation
my options are allowed, native or pruning
err nevermind that was the one that started out as a trunk... Let me check the IOS version.
It looks like it defaults to dot1q trunking but just take te encapsulation command off on both and it will default todynamic on the 6509 at least and will figure it out.
Avatar of B-SON

ASKER

On the 6509 here is the config for the port:
!
interface GigabitEthernet8/48
 switchport
 switchport access vlan 30
 no ip address
!
When I try to change the configuration to:

interface GigabitEthernet8/48
switchport mode trunk
switchport trunk allowed vlan 30
no ip address
I get the following error
Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode.

Thanks
If the mode is auto then the trunk should come up on it's own. do a "show interface trunk" to verify it's up.
Avatar of B-SON

ASKER

I have tried every config.  It will not pass VLan information so I can not pass traffic.
The error message on the 6509 means you just need to do the command

switchport trunk encapsulation dot1q

and then you can do the

switch mode trunk
 
Avatar of B-SON

ASKER

Here is my config on the 6509:

interface GigabitEthernet8/48
 switchport
 switchport access vlan 30
 switchport trunk encapsulation dot1q
 switchport mode trunk
 no ip address
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 description Management
 ip address 10.1.1.1 255.255.0.0
!
interface Vlan23
 ip address 10.6.23.1 255.255.255.0
!
interface Vlan24
 description Net_10.6.24.0/24-10.6.25.0/24
 ip address 10.6.25.1 255.255.255.0 secondary
 ip address 10.6.24.1 255.255.255.0
 ip helper-address 10.6.25.16
 no ip redirects
!
interface Vlan25
 no ip address
 shutdown
!
interface Vlan26
 description Net_10.6.26.0/24
 ip address 10.6.26.1 255.255.255.0
 ip helper-address 10.6.25.16
 no ip redirects
!
interface Vlan27
 description Net_10.6.27.0/24
 ip address 10.6.27.1 255.255.255.0
 ip helper-address 10.6.25.16
 no ip redirects
!
interface Vlan28
 description Net_10.6.28.0/24
 ip address 10.6.28.1 255.255.255.0
 ip helper-address 10.6.25.16
 no ip redirects
!
interface Vlan29
 description NET-10.6.29.0/24 - VPN Network
 ip address 10.6.29.1 255.255.255.0
 ip helper-address 10.6.25.16
 no ip redirects
!
interface Vlan30
 description Net_192.168.1.0/24 - Mail Route
 ip address 192.168.1.6 255.255.255.0
 ip helper-address 10.6.25.16
 no ip redirects

then on the port on the 2960G:
!
interface GigabitEthernet0/24
 description Uplink-DC-6509-Gi8/48
 switchport mode trunk

I am at my wits end..  I have configured many 3560 switches with no problems but this 2960G is giving me headaches.
!
Have you added ports into vlan 30 and created a vlan 30 on the switch itself?
Avatar of B-SON

ASKER

I have created the 30 VLan on the 6509 and it has propogated to my other switches but will not propogate to the 2960.  Should I have to create Vlan 30 on the 2960? All my Vlans are created on the 6509 and then I connect the swtiches to a port on the 6509 that allows access to the appropiate VLan.
On the for example 3560, I configure a port like this:
!
interface GigabitEthernet0/1
 description Uplink-DC-6509-Gi3/14
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
and i connect that port to the 6509 and it see all vlans and can connect to any vlan.

I appreciate all you are trying to do for me.

Thanks
ASKER CERTIFIED SOLUTION
Avatar of bkepford
bkepford
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
On the 6509:
Clear all  on the interface and paste this config:
conf t
interface GigabitEthernet8/48
Descr "whatever"
switchport mode trunk
switchport trunk encapsulation dot1q
spanning-tree portfast
no shut
( switchport trunk allowed vlan 30 ) try this after the trunk is up and running

on the 2960 :
Clear all  on the interface and paste this config:
conf t
interface GigabitEthernet0/24
Descr "whatever"
switchport mode trunk
switchport trunk encapsulation dot1q
spanning-tree portfast
no shut
( switchport trunk allowed vlan 30 ) try this after the trunk is up and running

for the config of the vlan you can use VTP:
If you want al vlans, make the 2960 switch a client. if you want to have only vlan 30 make the switch transparent and add vlan 30. make sure the vtp domain is the same on both switches.

do not use "switchport trunk allowed vlan 30 " until the trunk is working.

Good luck




Avatar of B-SON

ASKER

bkepford:
It was the VTP settings.  It is up and running now.  Thank you for all your assistance.