Link to home
Start Free TrialLog in
Avatar of c0rrupti0n
c0rrupti0n

asked on

Configuring a Cisco 806 Router with Bellsouth pppoe account

I recently purchased a Cisco 806 Router in hope of implementing it into an office with 40+ users.
I want to setup a Bellsouth DSL modem in bridge mode and have the router do the authenticating... I found a few sources on how to configure pppoe(w/ dynamic IP), however Im still having problems.
However Im rather new to the cisco world. I have a rough background, but I have a great understanding of networking in general.

The following is a PDF link about the 806 router. There is a how to for pppoe setup. But it doesnt seem to work.
http://www.cisco.com/application/pdf/en/us/guest/products/ps380/c1069/ccmigration_09186a00801c33c0.pdf

This is my current configuration:

Current configuration : 886 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname LPD-Dolphin
!
enable secret 5 $1$jrBG$lXyRbxXiaaTzYPbmMHLgT0
enable password **********
!
ip subnet-zero
!
vpdn enable
!
vpdn-group vpdngroup
 request-dialin
  protocol pppoe
!
!
!
!
!
interface Ethernet0
 ip address 192.168.0.254 255.255.255.0
 ip nat inside
 ip tcp adjust-mss 1452
 hold-queue 100 out
!
interface Ethernet1
 no ip address
 pppoe enable
 pppoe-client dial-pool-number 1
!
interface Dialer1
 ip address negotiated
 ip mtu 1492
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication pap callin
 ppp pap sent-username *****@bellsouth.net password 0 *****
!
ip classless
no ip http server
ip pim bidir-enable
!
!
!
line con 0
 stopbits 1
line vty 0 4
 password *******
 login
!
scheduler max-task-time 5000
end
Avatar of JFrederick29
JFrederick29
Flag of United States of America image

You need the following to complete your NAT configuration:

interface Dialer1
ip nat outside

ip nat inside source list 1 interface dialer1 overload

access-list 1 permit 192.168.0.0 0.0.0.255

And you need a default route to your ISP:

ip route 0.0.0.0 0.0.0.0 dialer1
You also need the following command:

dialer-list 1 protocol ip permit

To help troubleshoot, you can use the following commands:

debug dialer
debug ppp negotiation
debug ppp authentication

To turn off debugging:

undebug all
Avatar of c0rrupti0n
c0rrupti0n

ASKER

After following your instructions, Im still not net capable :(

What route is needed to my ISP? The primary DNS address? Or do I leave it as you wrote it with a 0.0.0.0?
"And you need a default route to your ISP:

ip route 0.0.0.0 0.0.0.0 dialer1"


Thanks for the swift response...
With the debug functions on I am now receiving the following:

LPD-Dolphin#
1d06h: %SYS-5-CONFIG_I: Configured from console by consoledebug dialer
Dial on demand events debugging is on
LPD-Dolphin#debug ppp negotiation
PPP protocol negotiation debugging is on
LPD-Dolphin#debug ppp authentication
PPP authentication debugging is on
LPD-Dolphin#
1d06h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet1, changed state
to up
1d06h: Di1 DDR: Cannot place call, no dialer string set
1d06h: Di1 DDR: Cannot place call, no dialer string set
1d06h: Di1 DDR: Cannot place call, no dialer string set
1d06h: Di1 DDR: Cannot place call, no dialer string set
1d06h: Di1 DDR: Cannot place call, no dialer string set
1d06h: Vi1 PPP: Phase is DOWN, Setup
1d06h: %DIALER-6-BIND: Interface Vi1 bound to profile Di1
1d06h: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
1d06h: Vi1 DDR: Dialer statechange to up
1d06h: Vi1 PPP: Treating connection as a callout
1d06h: Vi1 PPP: Phase is ESTABLISHING, Active Open
1d06h: Vi1 PPP: Authorization NOT required
1d06h: Vi1 PPP: No remote authentication for call-out
1d06h: Vi1 LCP: O CONFREQ [Closed] id 1 len 10
1d06h: Vi1 LCP:    MagicNumber 0x102E3441 (0x0506102E3441)
1d06h: Vi1 LCP: I CONFREQ [REQsent] id 46 len 19
1d06h: Vi1 LCP:    MagicNumber 0x7A74030B (0x05067A74030B)
1d06h: Vi1 LCP:    MRU 1500 (0x010405DC)
1d06h: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
1d06h: Vi1 LCP:    MagicNumber 0x7A74030B (0x05067A74030B)
1d06h: Vi1 LCP:    MRU 1500 (0x010405DC)
1d06h: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
1d06h: Vi1 LCP: O CONFACK [REQsent] id 46 len 19
1d06h: Vi1 LCP:    MagicNumber 0x7A74030B (0x05067A74030B)
1d06h: Vi1 LCP:    MRU 1500 (0x010405DC)
1d06h: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
1d06h: Vi1 LCP: I CONFACK [ACKsent] id 1 len 10
1d06h: Vi1 LCP:    MagicNumber 0x102E3441 (0x0506102E3441)
1d06h: Vi1 LCP: State is Open
1d06h: Vi1 PPP: Phase is AUTHENTICATING, by the peer
1d06h: Vi1 CHAP: I CHALLENGE id 1 len 32 from "miamflgr73w"
1d06h: Vi1 CHAP: Unable to authenticate for peer
1d06h: Vi1 PPP: Phase is TERMINATING
1d06h: Vi1 LCP: O TERMREQ [Open] id 2 len 4
1d06h: Vi1 LCP: I TERMACK [TERMsent] id 2 len 4
1d06h: Vi1 LCP: State is Closed
1d06h: Vi1 PPP: Phase is DOWN
1d06h: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di1
1d06h: Vi1 PPP: Phase is ESTABLISHING, Passive Open
1d06h: Vi1 LCP: State is Listen
1d06h: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
1d06h: Vi1 LCP: State is Closed
1d06h: Vi1 PPP: Phase is DOWN
Not an Expert in any way, but the debug states = "1d06h: Vi1 LCP:    AuthProto CHAP (0x0305C22305)"

Your config looks like you only have PAP configured...

/alkabello
uhh damn well thanks :\
Anybody Else? Help?
Pointed Increased...
ASKER CERTIFIED SOLUTION
Avatar of JFrederick29
JFrederick29
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial