<

SharePoint 2010 RTM Installation Timeout

Published on
9,243 Points
3,243 Views
Last Modified:
Approved
When installing SharePoint 2010 RTM I came across a strange error, I was getting timeouts during the installation.

I searched the web and found the best solution to be found here.

Becasue there are several fixes on this blog I have included the part that works for me:

It seems like it is happening because of the service account.  I was trying to do this on my virtual machine's DC, and it got stuck since it was pointing to Local Service account. The moment I changed it to Local System, the configuration zipped through. I tried the same thing twice, and it worked fine both the times. So, the trick is to run the PSConfigUI.exe and the moment you get to the SharePoint Search service, switch back to the Services console, change the user to Local System, and restart the service. The installation succeeds after that.

Thanks,
Rahul

Basically SharePoint install deletes and recreates the registry entries for these Services and assigns Local Service Account .  This account does not have the necessary authority and therefore stops.  You need to change the services to have the correct account type inflight, when it stops at installing the two services...

There are two Services that this applies to:

SharePoint Foundation Search Service and
SharePoint Search Service

This caused me hours worth of issues until I found the post as noted.

regards
0
Author:SMcP
Ask questions about what you read
If you have a question about something within an article, you can receive help directly from the article author. Experts Exchange article authors are available to answer questions and further the discussion.
Get 7 days free