[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 965
  • Last Modified:

problem with e2fsck

When I run e2fsck, I get the following message:

>  Parallelizing fsck version 0.5b (14-Feb-95)
>  e2fsck 0.5b, 14-Feb-95 for EXT2 FS 0.5b, 95/03/19
>  Warning: Inode table 751557 for group 90 not in group.
>  WARNING: SEVERE DATA LOSS POSSIBLE.
>  Continue<y>? yes

>  /dev/hda4 contains a filesystem with errors, check forced.
>  Pass 1: Checking inodes, blocks, and sizes
>  Relocating group 90's inode table to 751557...
>  Restarting e2fsck from the beginning...

At this point it repeats the same message, in a seemingly infinite loop.

If I try to mount the partition, I get this message:

>  mount: wrong fs type or bad superblock on /dev/hda4

I tried using fsck with other superblocks on the partition, but I get the same
result.

Any suggestions would be appreciated!
0
7c06
Asked:
7c06
1 Solution
 
mstongeCommented:
Looks bad but here is something I would try before turning this drive into free space.

try e2fsck -b 32

32 is where solaris keeps a spare copy of the superblock and I don't know where linux does but it's a good try.  If 32 don't work try using another superblock number, at this point your options are limited.

It's a shot in the dark but it may work.

Marc
mstonge@jklmicro.com
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now