Win '95 ignoring some drives

I installed a new 1MB hard drive in my computer (Gateway Pentium P5-60) today. I am running Windows '95.  I set it up as the "slave" hard drive with my original hard drive (C:) as the "master."  Using FDISK, I "created an extended DOS partition" on the new drive, and then created three logical drives on that partition.  Essentially, I created drives
D:, E:, and F: all on the new drive (to get smaller cluster sizes on each). I then formatted each of drives D, E, and F.

All this worked as intended.  I now have drives C, D, E, and F on hard disk, and WIN '95 correctly moved my CD-ROM drive down to drive G.  I can access all the drives from DOS; from Windows '95, if I use the (holdover from Windows 3.x) File Manager, it sees all of my drives correctly.  Also, the Control Panel/System/Device Manager/... series of screens recognizes all of my hard drives and my CD-ROM drive.  However, the rest of Windows '95 only sees drives C and D -- not E or F, and not my CD-ROM drive G. When I say the "rest of Win 95" I mean "My Computer" and Explorer.  Since I use Explorer extensively to move files between drives and directories, I can't get by without it recognizing all my drives.

The Gateway Technical support person tried a few ideas -- such as removing the "LASTDRIVE=K" line from CONFIG.SYS -- with no luck.  

Any suggestions on how to get Win 95 to see all my logical drives and the CD-ROM drive?
goodwinnAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

heyzeusCommented:
Here's a few things to try:
Load Win95 as you normally do.  Open a DOS box.  Type 'E:' to get to drive E.  Type 'start .' (that's start and a period).  This should open a window for the root directory of drive E.  Then push the BackSpace key.  This should open the My Computer window.  What is in this window?  (or what happened instead / what error msgs did you get?)
With Win95, there is not a need for autoexec.bat or config.sys files, unless you need DOS drivers.  For example, my autoexec.bat file only loads doskey for me.  I do not have a config.sys file.  Try renaming these files (make the extension .old or something) and reboot.
If this doesn't help try running windows in safe mode (push F8 when you see the message "Starting Windows 95").  Does this help?
Open the control panel, open System.  Check everything under 'disk drives', 'hard disk controllers', and 'scsi controllers' (if you have a scsi hard drive).  Make sure there are no conflicts.  Under 'disk drives' choose your hard drive, list properties, choose settings tab, see that current drive letter assignments include all that should be there (C, D, E, F).
I have one HD with a primary partition (C), secondary partition with 2 logical partitions (D and E).  All show up in My computer / Explorer / etc...
Another idea - call Gateway again.  Not all of their staff is equally knowledgeable (yes, i own a gateway...).
Good luck!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.