Solved

RX packet errors

Posted on 1997-02-01
1
1,266 Views
Last Modified: 2008-03-03
I have a 28.8 modem
I use dip to contact the service provider.
I used setserial to set my /dev/cua2 to spd_vhi and hardware handshaking etc.
However, I only seem to be able to achieve 1kb/s in ftp transfers and when using X (and netscape) the number of RX packet errors just goes sky high.  Note that under windows everything works very well and my modem always transfers at 28.8.

Here is a bit of a transcript from ifconfig:
<...>
UP POINTOPOINT RUNNING MTU: 1500 Metric: 1
RX packets: 477 errors: 153 dropped: 0 overrun: 0
TX packets: 634 errors: 0 dropped: 0 overrun: 0

The RX packet errors only seem to be skyhigh when I run X. Normally, the number of RX packet errors is much lower, (but I still don't seem to transfer very fast.)
I run linux on my 486DX/33 8MB RAM.  Any answers, as well as tips for optimizing the speed of my connection would be appreciated.

David
0
Comment
Question by:clark020197
1 Comment
 
LVL 1

Accepted Solution

by:
northwind earned 100 total points
ID: 1584118
I think there is only one answer to this and you more or less know it.
Windows work, but Linux doesn't ?
OK the only way I see it is that under windows your modem setup includes CTS/RTS control (hardware instead of XON/XOFF which is software)
Under Linux it for some reason doesn't in the setup you have.
Include the "crtscts" option in your pppd call.

The many missed RX packets are because your machine cant control the flow, and the max speed of an XON/XOFF transmission is ... 9600.
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Established in 1997, Technology Architects has become one of the most reputable technology solutions companies in the country. TA have been providing businesses with cost effective state-of-the-art solutions and unparalleled service that is designed…

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question