We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you two Citrix podcasts. Learn about 2020 trends and get answers to your biggest Citrix questions!Listen Now

x

Slackware96 (InfoMagic) booting problems

hpyrep
hpyrep asked
on
Medium Priority
238 Views
Last Modified: 2013-12-15
After I got Linux installed on my "D" drive (850megs Seagate partioned as a DOS backup site (410megs) and (440megs) as the Linux native and Swap (16megs) partions) and I tried to boot my machine LILO runs and loads Linux unless I use a DOS boot disk.  When I do get to DOS (using the DOS boot disk) I can't get in to Windows.  All of the DOS commands I use come back with error messages such as "Bad command or file name" and "Invaled dir" (Windows).  Also, I could not get into my system (autoexec.bat or config.sys) files or any utilities.

As for Linux, I got things going pretty good, I guess.  I think Linux found my modem and I was able to change the machine name, password protect the root dir, add a user account, and even play a couple of games of Tetris ;-)

I am using an AcerPower desk top computer (60mhz) with 16megs of RAM, the Seagate I mentioned above, a second hard drive 550megs ("C") by Maxtor, and an ATAPI CD-ROM (I had to set the CD to "Master" to get it to work with the InfoMagic CD.

Any help on this would be greatly appreciated.  Then I can get into more trouble setting up the X Window system and ask you more question.

Thanks,
hpyrep
Comment
Watch Question

Commented:
Of course nothing works when you boot DOS off the dis.  (A)
nothings in your path, and (B) the DOS boot floppy just contains
a minimal set of commands anyway.  Ultimately you want to add
an entry for DOS in your /etc/lilo.conf, then you can do away
with the floppy entirely.

My /etc/lilo.conf looks like this:
boot=/dev/hda
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
image=/boot/zImage
        label=zImage
        root=/dev/hda2
        read-only
other=/dev/hda1
        label=win95
        table=/dev/hda

So at the LILO prompt at boot time (You may have to hit
the LEFT-SHIFT button on your keyboard for LILO to allow
you to enter your choice of which OS to load) I choose
either linux or win95 (yeah, right!)  

Remember, after modifying your /etc/lilo.conf, you must
run /sbin/lilo to update your master boot record.  It
will make the changes, and the next time you boot, you should
be able to go into DOS with no problems at all.

Just a note of interest:  Whichever entry you list FIRST
in LILO, will be the one that will automatically boot up
if you do not make a choice at the prompt.

Good luck!

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.