need uc300 scanner driver

Where can I get Plug-in 2.5 -the driver for UMAX uc300 for use with Mac. I have an LC 630 with sys. 7.5.3. I have been to the UMAX home page with no luck except to find out that this is the driver required--they don't reply. I've tried Plug-in 3.5 for the UC 630 with no luck.
mac catAsked:
Who is Participating?
 
scottrConnect With a Mentor Commented:
I found the plugin25 at ftp.umax.com/umax/plugin25.sea.hqx.  In your URL type ftp://ftp.umax.com/umax/plugin25.sea.hqx, that should do it for you;)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.