PPP Problem

I am using Slackware 96 (kernel 2.0) with ppd 2.2. When I try to
connect nothing happens. My modem is set up on Dos Comm 1 and works
fine under minicom. I had this working before but can't seem to make
any progress now. I have included the revelent portion of my system
log at the end of this message. Here are my scripts:
/etc/ppp/ppp-on-dialer
#!/bin/sh
#
# This is part 2 of the ppp-on script. It will perform the connection
# protocol for the desired connection.
#
exec /usr/sbin/chat -v                                          \
        TIMEOUT         10                              \
        ABORT           '\nBUSY\r'                      \
        ABORT           '\nNO ANSWER\r'                 \
        ABORT           '\nRINGING\r\n\r\nRINGING\r'    \
        ''              \rAT                            \
        'OK-+++\c-OK'   ATH0                            \
        TIMEOUT         30                              \
        OK              ATDT$TELEPHONE                  \
        CONNECT         ''                              \
        ogin:--ogin:    $ACCOUNT                        \
        assword:        $PASSWORD

/usr/sbin/ppp-on
#!/bin/sh
#
# Script to initiate a ppp connection. This is the first part of the
# pair of scripts. This is not a secure pair of scripts as the codes
# are visible with the 'ps' command.  However, it is simple.
#
# These are the parameters. Change as needed.
TELEPHONE=555-1212      # The telephone number for the connection
ACCOUNT=george          # The account name for logon (as in 'George
Burns')
PASSWORD=gracie         # The password for this account (and 'Gracie
Allen')
LOCAL_IP=0.0.0.0        # Local IP address if known. Dynamic = 0.0.0.0
REMOTE_IP=0.0.0.0       # Remote IP address if desired. Normally
0.0.0.0
NETMASK=255.255.255.0   # The proper netmask if needed
#
# Export them so that they will be available at 'ppp-on-dialer' time.
export TELEPHONE ACCOUNT PASSWORD
#
# This is the location of the script which dials the phone and logs
# in.  Please use the absolute file name as the $PATH variable is not
# used on the connect option.  (To do so on a 'root' account would be
# a security hole so don't ask.)
#
DIALER_SCRIPT=/etc/ppp/ppp-on-dialer
#
# Initiate the connection
#
# I put most of the common options on this command. Please, don't
# forget the 'lock' option or some programs such as mgetty will not
# work. The asyncmap and escape will permit the PPP link to work with
# a telnet or rlogin connection. You are welcome to make any changes
# as desired. Don't use the 'defaultroute' option if you currently
# have a default route to an ethernet gateway.
#
exec /usr/sbin/pppd debug lock modem crtscts /dev/ttyS0 38400 \
        asyncmap 20A0000 escape FF kdebug 0 $LOCAL_IP:$REMOTE_IP \
        noipdefault netmask $NETMASK defaultroute connect
$DIALER_SCRIPT

/var/log/messages
----snip----
Feb 17 14:08:57 booger pppd[92]: pppd 2.2.0 started by root, uid 0
Feb 17 14:08:58 booger chat[93]: timeout set to 10 seconds
Feb 17 14:08:58 booger chat[93]: abort on (\nBUSY\r)
Feb 17 14:08:58 booger chat[93]: abort on (\nNO ANSWER\r)
Feb 17 14:08:58 booger chat[93]: abort on (\nRINGING\r\n\r\nRINGING\r)

Feb 17 14:08:58 booger chat[93]: send (rAT^M)
Feb 17 14:08:58 booger chat[93]: expect (OK)
Feb 17 14:09:08 booger chat[93]: alarm
Feb 17 14:09:08 booger chat[93]: send (+++)
Feb 17 14:09:08 booger chat[93]: expect (OK)
Feb 17 14:09:18 booger chat[93]: alarm
Feb 17 14:09:18 booger chat[93]: Failed
Feb 17 14:09:18 booger pppd[92]: Exit.

Thanks in advance for any help you can offer....
crash@exo.comAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rayc021897Commented:
ppp scripts changed alot between 1.0 kernels and 2.0
you MUST have the latest greates pppd 2.2.0-f I think?!?!?

I will e-mail you a copy of my condensed ppp script later this afternoon.  It is a lot simpler and usually easier to get working.

Good Luck,

Ray

rayc@indy.net
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.