diald/dynamic IP: problem persists

Hmmm... Don't know why the question vanished...

Well, it's still not working.  :-(

My diald config by now:
mode slip
mtu 1006
local    # fake IP
remote  # remote IP is known
dlip-mode local
-reroute  # tried reroute, as well
device /dev/modem
connect '...
speed 57600
-f /etc/...
fifo ...

upgraded kernel to 2.0.29,
diald 0.16
net-tools 1.32 alpha

it seems that diald *does* send the first packets, but still with the fake IP as source address. So I never get an answer.

What's the trick?

I've been thinking about modifying diald to correct the IP in buffered packets before they get send out. (Looked at code, seems pretty easy).
Would that make sense? Or would whichever program sent that packet be confused, because it expected to be using the fake IP?

Thanks a lot for your assistance,

Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Ever thought about using ppp via diald?
rupertAuthor Commented:
Not an option, neither is static IP.  :(

Tried 'noipdefault' and using as your locIP ?
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

rupertAuthor Commented:
noipdefault is a pppd-option, though. I use SLIP.
rupertAuthor Commented:
Adjusted points to 147
rupertAuthor Commented:
ok, I got a ppp connection now, still with dynamic IP address.
It still doesn't work!
rupertAuthor Commented:
Quite some experts here...

I've got the problem solved now. It required a change to the kernel if one didn't want to rewrite ip-masquerading - which I almost did.

So much for 'I got it working' from whoever cashed in the points when I asked the question the first time.

I'm out of here...
I can suggest you to take a look at the new ppp-2.3.0
now there is a new included "dial on demand" feature.

Let me know....

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.