• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 207
  • Last Modified:

Linux boot Initials

I just recompiled my Redhat 4.1 kernal, since I removed
some unnessasary kernal loadin drivers, when the new kernal
boot up, it no longer can load in those modules, so that
print out a lot of error message. I just want to remove
those insmod instructions from boot time, but I cannot
locate the initial script which does those insmod.

Thanks,
Yadong
0
yadong
Asked:
yadong
1 Solution
 
rdhillhoCommented:
I too have had this problem.  There are two fixes
1.  Quick fix (Works for me)
   When configuring you kernel with 'make config'
   Select no to set version information on all symbols for
   modules.  This is safe if you aren't adding special modules
   (other than came with redhat) because they're going to be
   recompiled anyways.  This will eliminate the error message
2.  If you need to have the set version information flag on
   then execute 'find . -name <module name>' from the root
   directory and delete the modules that you don't need anymore
   with your new kernel.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now