Solved

3COM 3c509b configuration

Posted on 1997-02-25
5
270 Views
Last Modified: 2012-05-04
I have a Linux machine (Linux 1.2.13) with a 3COM ehernet card (3c509) plugged in it. I'd like to connect my machine to the local network of our university. Everything is well configured but i can't reach the network. While loading Linux i have got these messages:

eth0: ewrk3_probe(): Detected a device already registred at 0x2e0
eth0: ewrk3_probe(): Detected a device already registred at 0x360
eth0: ewrk3_probe(): Detected a device already registred at 0x3c0

and after, i got these messages:

SIOCSIFADDR: No such device
SIOCSIFBRDADDR: No such device
SIOCSIFNETMASK: No such device
SIOCADDRT: Network is unreachable
SIOCADDRT: Network is unreachable

I would add that under Windows95 everything is ok, and that it informs me that i have a "3COM EtherLink III ISA (3C509/3C509b) in ISA mode", and that my card uses a set I/O adresses between 0300 and 030F, and an IRQ of 10.

I have disabled the Plug and Play function on the 3Com card (via the 3c5x9cfg.exe configuration file) and tried to boot Linux with the following parameters (just after typing linux): ether=0x300,10,eth0
,but linux tells me that ther's no device at 0x000a and that my network is still unreachable.

So can you tell me what should i do.
0
Comment
Question by:hmida
  • 2
  • 2
5 Comments
 

Expert Comment

by:timc
ID: 1584139
When you ran 3c5x9cfg, did you try to rerun the auto-setup function as well?  I've found in the past with some 3COM cards if they won't play under Linux, the best bet will be to disable the PnP (as you've done) and then run auto-config in the setup to make sure there are no conflicts with any other devices in your system.  The 3COM setup program is usually pretty good at picking a free interrupt and address, even though your card may be set to 10 and 0x300 currently.  The other addresses mentioned upon Linux bootup appear a little strange; what other devices do you have in your system (ie. sound card etc) and how are they configured?

Also - do you have a PnP motherboard Bios?  If so, once you've set your network card to use a particular IRQ, make sure your MB Bios is not trying to automagically PnP assign that irq to other devices; ie. set it for the ISA (or similar) setting instead.

0
 

Author Comment

by:hmida
ID: 1584140
I did what "timc" suggested in his comment (i executed the command 3c5x9cfg /pnprst to disable PnP mode, and after that 3c5x9cfg configure /auto in order to auto-config my card).
I think i also set the IRQ10 to ISA instead of PnP.
Once the configuration has finished, i tried to boot Linux with the parameter ether=0x300,10,eth0. Again my problem is persisting: "cannot find a device at 0x000a".


0
 
LVL 1

Accepted Solution

by:
ping0621 earned 50 total points
ID: 1584141
eth0: ewrk3_probe(): Detected a device already registred at 0x2e0
What card is it Etherlink III (3COM) or Etherworks 3 (Digital) ?
Try to recompile your kernel and don't add the probe for Etherworks NIC (other ISA cards)
0
 

Author Comment

by:hmida
ID: 1584142
As "ping0621" proposed, i recompiled my Kernel and did not add the probe for Etherworks NIC (other ISA cards). Now i have Linux 2.0.27. The message eth0: detected a device already registred at 0x2e0 has disapeared but i still have the messages "... NO such device" and "... Network is unreachable".

I don't know what to do !!!
0
 
LVL 1

Expert Comment

by:ping0621
ID: 1584143
Check the settings with the setupdisk delivered with the NIC.
Try to change the I/O from 0x2e0 to 0x300 and set IRQ=5.
Sometimes 0x2e0 gives a conflict with something but can't remember with what exactly (I think a videocard).
Specify your TCP/IP address without leading zeroes.
e.g. 192.168.2.1 and *NOT* 192.168.002.001

0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
This video explains how to create simple products associated to Magento configurable product and offers fast way of their generation with Store Manager for Magento tool.

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now