EtherExpress Pro module installation failure

Hello,
We've successfully installed the new Debian Linux, except that the EtherExpress Pro/10+ card driver won't seem to install.  The details are below; does anyone have any ideas as to what the problem might be, or can you point me to where I might be able to find the solution?
Thanks,
David Scott Farrar
UCSD Cognitive Science
farrar@cogsci.ucsd.edu

--The Details---------------------------------------------

We're trying to install Debian GNU/Linux (from CD-ROM) version 1.2.6, Kernel 2.0.27 on a 180MHz PentiumPro with an Intel Etherexpress Pro/10+ ISA card.  Following the instructions in the document "install.txt", we
were able to install everything except the device driver module for our ethernet card, "eepro".  When we select "Configure Device Driver Modules" and choose "eepro", we get the message:
        loading device 'eth0'
        Initialization of eepro failed
        Installation failed.

From a Windows 95 partition, the card seems to work fine; Windows recognizes the card as an "Intel EtherExpress PRO/10 (PnP Enabled)", and we are able to run Netscape, etc.  Under the Windows System Properties/Device Manager/Resources tab, the card uses I/O range 0x230-0x23F and IRQ 09.  Windows does not detect any device conflicts with these resources.

During a linux boot, there are no ethernet device messages
"eth0:...et.c".  From linux, a "cat /proc/ioports" shows no devices at all in the range of 0x200-0x2F7, and "cat /proc/interrupts" shows that irq 9 is not used.  We tried passing ethernet arguments to the kernel:
        linux ether=9,0x230,0,0,eth0
and we tried loading the "eepro" module after booting linux:
        insmod eepro
        insmod eepro io=0x230 irq=9    (From Windows Resources tab)
        insmod eepro io=0x200 irq=0
         (From /usr/src/linux/Documentation/networking/net-modules.txt)
both fail to install and give the same error message:
        loading device 'eth0'
        Initialization of eepro failed
We built a new kernel specifically including the Etherexpress Pro driver, but we get no ethernet device messages during boot, nor does the device appear in /dev.

We're baffled.  Any suggestions would be greatly appreciated, and can be sent to:   farrar@cogsci.ucsd.edu
Thanks!

farrarAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

duxCommented:
Look at
http://cesdis.gsfc.nasa.gov/linux/drivers/eepro100.html
There you can find detailed instruction about your question.
Good Luck!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
farrarAuthor Commented:
The website page:
http://cesdis.gsfc.nasa.gov/linux/drivers/eepro100.html 
has instructions for the EtherExpress Pro/100.  I looked around the same site, however, and found instructions and new driver source code for the card I have, the EtherExpress Pro/10+ ISA
(http://titan.cs.uni-bonn.ed/~canavan/eepro.c).  I recompiled the kernel and the modules with the new driver source code, but I get the same behavior:
    loading device 'eth0'
    Initialization of eepro failed
Sigh...

0
duxCommented:
Compile your kernel with EtherExpress Pro/10+ support, not module.
0
farrarAuthor Commented:
When I compiled the Pro/10+ driver, I put it in the kernel (not as a loadable module).  The behavior was still the same as before (no ethernet device messages during bootup).  And after booting up, I tried 'insmod' (as before, with&without io/irqs), but still no change.

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.