Solved

syslogd help

Posted on 1997-03-05
3
377 Views
Last Modified: 2013-12-15
I just ran into a problem with my linux box.  Here it is:  my
/usr/adm/messages file doesnt tell me important system info anymore???

Here is the last few lines in the file:

Mar  2 02:42:20 kabal pppd[2930]: Terminating on signal 2.
Mar  2 02:42:20 kabal pppd[2930]: Connection terminated.
Mar  2 02:42:20 kabal pppd[2930]: Exit.
Mar  2 02:42:54 kabal init: Switching to runlevel: 6

Ever since then, everytime I invoke pppd, this file doesnt tell me.
Normally i run a tail -f /usr/adm/messages in the top right of my Xdisplay so i can c if anyone tries to telnet, ftp, rlogin into my machine, etc.

Now, this file no longer does that.  Not only that, but it doesnt tell me
when I su either???  I have no clue why this is happening.

I have run /sbin/runlevel and I am running in runlevel three.  Also, when
i ps -auxw | more,  the init process is set to [3].

I am running slackware linux kernel 2.0

I'd like to follow up my previous post about my problem with the
/usr/adm/messages file with this:

one of my friends mentionted that i should have klogd and syslogd running
in order for the file to capture sysinfo.  well i did a ps for the daemons
and sure enough syslogd is not running... i tried running syslogd manually
from the command line, but when i do  a ps after this, this is what i get:

root       163  0.0  1.9   772   292  p2 S    22:48   0:00
/usr/sbin/syslogd
root       164  0.0  0.0     0     0  ?  Z    22:48   0:00 (syslogd
<zombie>)

what is this <zombie>?  anyway, this is not a fix for my problem since the
messages file still does no reporting...  
AND, when i do a ps about 5 minutes after invoking syslogd, the daemon is
no longer running??  

i've tried doing a man on syslogd but got no man page on it.  one more
point of interest is when i boot up my system and all of my daemons are
invoked, there is an unusually long pause after the syslogd daemon.  this
has never happened before and i am at my wits end.

another point of interest is that everytime i run syslogd,
the program creates a core file... i ran "file core" on the
core file and here is what i got:

core: ELF 32-bit LSB core file i386 (386 and up) Version 1

I hope this is enough info for someone to be able to help.

Thanks alot.

serge

0
Comment
Question by:compreal
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 1

Expert Comment

by:ggeens
ID: 1626747
Did you install new packages, libraries, ... just before these last lines?
Did you have a disk crash?
Did you change anything in one of your setup files?

The <zombie> means the proces has already died, but its parent hasn't acknowledged this. The zombie should go away after the other syslogd proces ends.

Try running syslogd with the -d flag (for debugging). Look at the file /etc/syslogd.conf to find out if there is something strange. If possible, compare it to your backup.

Also, it's strange that you don't have a syslogd man page. This would indicate an installation failure. It should be in /usr/man/man8 . What does `man 8 sysklogd' (note the k) say?
0
 

Author Comment

by:compreal
ID: 1626748
When I ran syslogd -d, I got a
"segmentation fault: (core dumped)"

I looked at /etc/syslog.conf and the file looks normal to me.
Here is what it says:

# /etc/syslog.conf
# For info about the format of this file, see "man syslog.conf" (the BSD man
# page), and /usr/doc/sysklogd/README.linux.
#
# NOTE: YOU HAVE TO USE TABS HERE - NOT SPACES.
# I don't know why.
#

*.=info;*.=notice                               /usr/adm/messages
*.=debug                                        /usr/adm/debug
*.warn                                          /usr/adm/syslog

#
# This might work instead to log on a remote host:
# *                     @hostname

BTW, I do have man pages on syslogd.  The proper syntax is not
"man syslogd" but rather "man 8 sysklogd"

I'm still hacking away trying to resolve this conflict.  All help
is very appreciated.  

Thanks alot

Serge

PS.  You can contact me at my email address at compreal@panix.com

0
 

Accepted Solution

by:
elio071697 earned 50 total points
ID: 1626749
I had the same problem; it is related to having not set the
domainname and a bug in the syslogd code. A patched sysklogd is available.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How many times have you wanted to quickly do the same thing to a list but found yourself typing it again and again? I first figured out a small time saver with the up arrow to recall the last command but that can only get you so far if you have a bi…
SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

691 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question