Solved

Mouse problems...

Posted on 1997-03-10
6
225 Views
Last Modified: 2013-12-15
Well, I got my X server set up but I have one more problem to overcome...my mouse does not work. This seems like it will be an easy problem to overcome since this is such  a basic item. I have a Microsoft brand mouse which has a sticker underneath it describing it as Mouse Port Compatible Mouse 2.0A (FYI, it has a PS/2 connector). This is a very standard mouse which comes with MANY computer systems.When X starts up, the mouse immediately goes to the stop of the screen. I can jerk it about a little bit, but it always jumps back to the upper left of the screen. This sounds like a protocol problem but i have tried both the PS/2 and the Microsoft ones without success. I have also tried /dev/psaux, /dev/ttyS0, and dev/mouse with no luck.None of these settings work.I am using Slackware96...are there any mouse fixes available? I downloaded XFree86 3.2 off the net. Any suggestions?

P.S. Yes, the mouse does work... here I am zipping around in Win95 clicking and dragging ;-)

--
Nicholas Gates
gates@ibm.net
0
Comment
Question by:ncgates
6 Comments
 
LVL 19

Expert Comment

by:xterm
ID: 1626984
If you don't have /dev/psaux then:
mknod /dev/psaux    c 10 1
(do that as root...)

Then after that (or if you have it already) do:
ln -s /dev/psaux /dev/mouse

Then tell XF86Config that you are using a PS/2
mouse, and voila...

Good luck
0
 

Author Comment

by:ncgates
ID: 1626985
Edited text of question
0
 

Author Comment

by:ncgates
ID: 1626986

0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
LVL 1

Expert Comment

by:ggeens
ID: 1626987
Try changing the Protocol line in the Pointer section in /etc/XF86Config .
As your mouse has a PS/2 socket, you could try to set it to `PS/2'.
For other possible values, read the man page on XF86Config .

0
 

Author Comment

by:ncgates
ID: 1626988
I already tried ggeens proposed solution and it didn't work.
0
 

Accepted Solution

by:
yadong earned 70 total points
ID: 1626989
From what you said, it looks like a configuration problem
in the XF86Config file under /etc/X11, you can directly edit
this file according to the explanation in the comment, or if
you have XF86Setup installed, you can run it for a graphical
interface of configuring your mouse
0

Featured Post

Master Your Team's Linux and Cloud Stack!

The average business loses $13.5M per year to ineffective training (per 1,000 employees). Keep ahead of the competition and combine in-person quality with online cost and flexibility by training with Linux Academy.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
Google Drive is extremely cheap offsite storage, and it's even possible to get extra storage for free for two years.  You can use the free account 15GB, and if you have an Android device..when you install Google Drive for the first time it will give…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question