DVIPS giving segmentation fault

Posted on 1997-03-11
Medium Priority
Last Modified: 2013-12-15
I just installed some of slackware96 3.0.1(from cdrom in a linux book). Everything is running ok(like latex, xfig, emacs etc) except dvips(for converting dvi files to ps files). When i run this it's giving me segmentation fault.
Can anyone suggest a solution? Can anyone tell me if I could download just dvips(a correct version) program for linuxfrom internet?

Question by:sujit
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3

Accepted Solution

ggeens earned 200 total points
ID: 1626754
I have seen other people mentioning this bug.
You can download a working version from a CTAN archive (Comprehensive TeX Archive Network).
The main sites are:
Look for teTeX. It should be in the systems/unix tree. There are binaries for Linux there.

I would advise to download the complete package, as teTeX is much faster than the NTeX that comes with Slackware. But I'm sure that you can download only dvips.

BTW: Slackware 3.0.1 is not the same as Slackware96 (which is 3.1). I suspect that you are using version 3.0 because that one has the faulty dvips.

Author Comment

ID: 1626755
This time I installed the binaries from:


And tried running dvips. The following error msg. is coming:

This is dvipsk 5.58f Copyright 1986, 1994 Radical Eye Software
/home/sujit/teTeX/bin/i386-linux/dvips: ! Couldn't find header file tex.pro

When I ran latex from this installation the following error msg is coming up:

This is TeX, Version 3.14159 (C version 6.1)
I can't find the default format file!
MAT/home/sujit/teTeX/bin/i386-linux:)which latex

Any suggestions please?


Author Comment

ID: 1626756
Correction: When I ran latex from the installed version I got the following msg.:

This is TeX, Version 3.14159 (C version 6.1)
I can't find the default format file!
10 Questions to Ask when Buying Backup Software

Choosing the right backup solution for your organization can be a daunting task. To make the selection process easier, ask solution providers these 10 key questions.


Expert Comment

ID: 1626757
You should set the environment variable TETEXDIR to point to
the place where you put the files.
(If you're using bash, you can add this to your .profile:
Also, you should run texconfig. (It is somewhere in the distribution.)
I believe that's all. Check the readme files to see if you need to do anything else.

Author Comment

ID: 1626758
I use csh. So I added:

setenv TETEXDIR /home/sujit/teTeX

in my .cshrc. When I ran texconfig i got the following eror:

texconfig: /tmp/texconf13458/logfile: No such file or directory
Press return to continue...

After this when I attempted to run dvips then I am getting the same error msg. as before:

This is dvipsk 5.58f Copyright 1986, 1994 Radical Eye Software
dvips: ! Couldn't find header file tex.pro

The error msg for runing latex remains the same as before.

Suggestions please!



Expert Comment

ID: 1626759
texconfig failed, so your problem hasn't changed. It might be a path problem.

Try adding $TETEXDIR/bin to your path.

If that doesn't work, I think you need to read all the documents in the package again carefully.

(My installation came from a CD-ROM originally, and things were a little different.)

Featured Post

Moving data to the cloud? Find out if you’re ready

Before moving to the cloud, it is important to carefully define your db needs, plan for the migration & understand prod. environment. This wp explains how to define what you need from a cloud provider, plan for the migration & what putting a cloud solution into practice entails.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction We as admins face situation where we need to redirect websites to another. This may be required as a part of an upgrade keeping the old URL but website should be served from new URL. This document would brief you on different ways ca…
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
Suggested Courses
Course of the Month13 days, 21 hours left to enroll

800 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question