[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

Netscape delay

Posted on 1997-03-13
10
Medium Priority
?
246 Views
Last Modified: 2013-12-15
Has it occured to anyone that after starting up
Netscape(3.0 or 3.01) the system (RedHat 4.1 16M RAM 45M swap) had you wait for 4 minutes. when i look with 'ps'
the process is there, but no window comes up and there is no swapping or anything suggesting that the system is working
towards starting Netscape.
The same thing happens when finally starting a java applet in Netscape; the first one take a couple of minutes to get going, after that it's OK.
0
Comment
Question by:kazic
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
10 Comments
 
LVL 1

Expert Comment

by:ggeens
ID: 1626828
Four minutes before Netscape starts up seems way to long to me.

Can you be a little more specific? What exactly happens during that time: does a window pop up? Is there something inside the window?
Is there any modem/network activity going?

0
 
LVL 1

Author Comment

by:kazic
ID: 1626829
Edited text of question
0
 
LVL 1

Author Comment

by:kazic
ID: 1626830
Edited text of question
0
Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

 

Expert Comment

by:timc
ID: 1626831
Good old Netscape.  If you looked at the size of the Netscape binary, no wonder your poor machine is sitting there.  Try the size of the Netscape Communicator v4.0 binary.  Have these people not heard of shared libraries :-)  16MB of RAM is probably not really enough for this beast of a program, considering OS and X's overhead etc.


0
 
LVL 1

Author Comment

by:kazic
ID: 1626832
timc !

i don't think that's the case. my slackware 3.0 needed less
than 10 secs with the same hardware.

0
 
LVL 1

Expert Comment

by:ggeens
ID: 1626833
Did you try running a top in another xterm during the startup period?
How much processor time is used by Netscape?
0
 
LVL 1

Author Comment

by:kazic
ID: 1626834
now i have it 'solved' though i'm not sure what caused it. i renamed the /etc/sysconfig/network file, so the NETWORKING wariable was set to NO at boot-time. Then it worked OK except that the 'shutdown' program didn't do anything, but after shutting down with 'halt' i named the /ect/sysconfig/network file  to it's original name and now life is good.
still i'd appreciate anyone telling what exactly happened.
0
 
LVL 1

Author Comment

by:kazic
ID: 1626835
now i have it 'solved' though i'm not sure what caused it. i renamed the /etc/sysconfig/network file, so the NETWORKING wariable was set to NO at boot-time. Then it worked OK except that the 'shutdown' program didn't do anything, but after shutting down with 'halt' i named the /ect/sysconfig/network file  to it's original name and now life is good.
still i'd appreciate anyone telling what exactly happened.
0
 
LVL 1

Accepted Solution

by:
ggeens earned 60 total points
ID: 1626836
From what I heard on usenet, the problem could be your /etc/hosts file and the name server. For some reason, Red Hat Linux starts up a nameserver (named).
So when you start up netscape, it tries to find your PC's IP address.
On my Slackware installation, the libraries would first look into /etc/hosts, and if it doesn't find it there, it will call named. This proces takes time.

The solution other people have used, is to kill named. Normally, you will not need it anyway.
To remove named from your boot sequence permanently, try Red Hat's configuration tool.
If you can't figure out howe to do it, you'll have to search the files in the /etc/ tree. Normally, I would suspect the filename includes the letters `rc'.
(Try find /etc -name '*rc*' -print | xargs grep named )
Add a # (sharp sign) before that line containing named.
0
 

Expert Comment

by:kaf
ID: 1626837
I think
you should also change "Home Page Location"
in Options-> General Preference or set it to Blank page.
If this link points to unreacheble or slow connected
host.

If you know pid of Netscape you can
execute:
strace -p Pid_of_Netscape
and to see what system calls execute Netscape
It helps to solve problems.
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
The purpose of this article is to demonstrate how we can use conditional statements using Python.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Suggested Courses

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question