Solved

Strange keyboard behaviour

Posted on 1997-03-13
4
312 Views
Last Modified: 2013-12-15
I have this rather strange thing with my keyboard...
I have suddenly my backspace key changing function in different programs. In shell, emacs, and most other programs it works as usual, deleting the character to the left of my cursor. But in netscape it works as the delete key erasing the character to the right... Also in xfmail it behaves strange. It is ok in the subject and to: fields but in the
message area it changes to delete.
The only things I have done lately on the box is installing Afterstep, removing it from the startx "script" to start fvwm95 instead. I unhooked the HD and plugged another in for a quick nfs setup for another box, replugged the original and rebooted again... Somewhere along that the strangeness have developed... As far as i can see no "system" files have been altered lately.
Does Afterstep ad something strange?
I tried to reinstall the fi-latin1 keyboard as i use that
That file is changed for swedish comlience by removing the "dead" from a few keys... But everything have worked without any flaws up till the other day.
PLEASE help! I go crazy on this...

/Rikard Johnels
/im@hem.passagen.se
0
Comment
Question by:im
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
4 Comments
 

Expert Comment

by:poke
ID: 1626991
Atleast for shell sessions you can type:
stty erase <TYPE ERASE KEY HERE>

This will make the typed key the backspace key. Hope that helps just a little bit :-)
0
 
LVL 2

Expert Comment

by:dux
ID: 1626992
The xkeycaps program that comes with common Linux distribution can set your keyboard behaviour. Is an X application, has a nice interface and supports lots of keboard types.
Even without it you can set your backspace key in the following files:

Slackware: /var/X11R6/lib/xinit/.Xmodmap
RedHat: /etc/X11/xinit/.Xmodmap

by adding the following line:

keycode 0x16 =  BackSpace


0
 

Author Comment

by:im
ID: 1626993
That would change the behaviour everywhere.
And this problem is just in a few places...

0
 

Accepted Solution

by:
nuno earned 150 total points
ID: 1626994
I had the same problem a long time ago...
I also use AfterStep, but the problem has nothing to do with AfterStep. What I did was to add to .steprc to the Initialization section this:

Exec    "I"     exec xmodmap -e "keycode 22 = BackSpace"


If you dont want to run AfterStep anymore just add this line to some file that i
s read when ya startx, like the windows manager rc file you use.
xmodmap -e "keycode 22 = BackSpace"

Hope it can help.. it worked for me...
0

Featured Post

On Demand Webinar - Networking for the Cloud Era

This webinar discusses:
-Common barriers companies experience when moving to the cloud
-How SD-WAN changes the way we look at networks
-Best practices customers should employ moving forward with cloud migration
-What happens behind the scenes of SteelConnect’s one-click button

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

It’s 2016. Password authentication should be dead — or at least close to dying. But, unfortunately, it has not traversed Quagga stage yet. Using password authentication is like laundering hotel guest linens with a washboard — it’s Passé.
In part one, we reviewed the prerequisites required for installing SQL Server vNext. In this part we will explore how to install Microsoft's SQL Server on Ubuntu 16.04.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Suggested Courses

632 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question