Japanese Win95 Control Panel turned to underscores

I am running Japanese Windows 95. While in SAFE MODE, all of the Japanese characters are changed to underscores, but everything still works. After exiting safe mode, the top half of the control panel entries are still all underscores and don't work anymore when accessed from the control panel.
How can I restore my control panel without reinstalling Win95?
gooAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

drathboneCommented:
Why did you originally enter Safe Mode ?

If, as I suspect, the control panel file, or control.ini, has become corrupt, then the easiest way to restore all is to re-install.

If you select to re-install you should be able to select -Install only damaged or deleted files. This will restore over the old control panel.

You could try and replace the files manually, but this can be lengthy, and dangerous.

Let me know how it goes...

0
gooAuthor Commented:
Sorry...

I specifically said that I didn't want to reinstall Win95. Even if there is an option for "Install only damaged or deleted files", I wouldn't be able to use it because all of the menus are in Japanese and my Japanese isn't good enough to discriminate that from the other options. Besides, I've spent a lot of time customizing and configuring my Windows 95 with proper drivers and options and reinstalling would erase all that. The task of reinstalling all of my drivers (in Japanese) just isn't worth it.

Now, can somebody offer me something other than the "default" solution?
0
stratariCommented:
1. Do you still have something like the below entries in you Autoexec.bat?
C:\WIN95\mode con codepage prepare=((737) C:\WIN95\COMMAND\ega2.cpi)
C:\WIN95\mode con codepage select=737
keyb gk,,C:\WIN95\COMMAND\keybrd4.sys

and those in Config.sys
Country=030,737,C:\WIN95\COMMAND\country.sys

All of the above change to greek. Check in D:\ADMIN\RESKIT\SAMPLES\SCRIPTS drawer of any W95 CD-ROM for the Japanese values.

2. Try to change the default font from Display properties.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.