Cannot ping peer at ISP using PPP

I am running RedHat 4.1 on an AMD 5x86.  I have a USR 28.8 modem.  I am running on kernel 2.0.27, and used RedHat's netcfg under X to configure PPP.

When I activate the ppp connection, the modem dials out and connects to the ISP.  The system log shows my local IP and the peer's, ifconfig shows the new interface, and netstat -nr shows the new route.  However, my peer at the ISP does not answer my pings, and neither do any of the nameservers.  Naturally, nothing else works.

The README in the pppd documentation suggests that after my PC has been assigned a local IP and the link is up, I should be able to ping some machine on the remote network, if not necessarily my peer.  However nothing works.

I hope you folks can help me.  Thanks in advance!
gaponAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

KallistiCommented:
It might be useful to see exactly WHAT netstat outputs.

For that matter, the output of "route" would be very useful
as well.
0
gaponAuthor Commented:
Kallisti,

Here's 'tail /var/log/messages' after I connect:

Mar 25 22:34:51 fnord ifup-ppp: pppd started for ppp0 on /dev/modem at 115200
Mar 25 22:34:52 fnord kernel: CSLIP: code copyright 1989 Regents of the University of California
Mar 25 22:34:52 fnord kernel: PPP: version 2.2.0 (dynamic channel allocation)
Mar 25 22:34:52 fnord kernel: PPP Dynamic channel allocation code copyright 1995 Caldera, Inc.
Mar 25 22:34:52 fnord kernel: PPP line discipline registered.
Mar 25 22:34:52 fnord kernel: registered device ppp0
Mar 25 22:34:52 fnord pppd[416]: pppd 2.2.0 started by root, uid 0
Mar 25 22:35:17 fnord pppd[416]: Serial connection established.
Mar 25 22:35:18 fnord pppd[416]: Using interface ppp0
Mar 25 22:35:18 fnord pppd[416]: Connect: ppp0 <--> /dev/modem
Mar 25 22:35:21 fnord pppd[416]: local  IP address 198.178.203.117
Mar 25 22:35:21 fnord pppd[416]: remote IP address 198.178.203.14

Here's the output of ifconfig:

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Bcast:127.255.255.255  Mask:255.0.0.0
          UP BROADCAST LOOPBACK RUNNING  MTU:3584  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0
          TX packets:0 errors:0 dropped:0 overruns:0

ppp0      Link encap:Point-Point Protocol  
          inet addr:198.178.203.117  P-t-P:198.178.203.14  Mask:255.255.255.0
          UP POINTOPOINT RUNNING  MTU:1500  Metric:1
          RX packets:5 errors:0 dropped:0 overruns:0
          TX packets:14 errors:0 dropped:0 overruns:0

And here's 'netstat -nr':

Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
198.178.203.14  0.0.0.0         255.255.255.255 UH     1500 0          0 ppp0
127.0.0.0       0.0.0.0         255.0.0.0       U      3584 0          0 lo
0.0.0.0         198.178.203.14  0.0.0.0         UG     1500 0          0 ppp0

Thank you very much!
Hail Eris
0
crbildCommented:
How are the parameters you have for ppp ?

anything about route ?

maybe you don't have the default gateway setted.

if you want to add yourself do this:

route add default gw ppp0_address_interface
0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

KallistiCommented:
All hail discordia,

Uhh, you did not include the output from 'route'.
However, the output from netstat -nr seems a bit
odd.  Try:

route del 0.0.0.0
route add default dev ppp0

If that does not work, refuse this, and include
your output from 'route'  (I can understand that
a lot more easily!)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
KallistiCommented:
You didn't say if you're on a local network or not!
If you are, can I see your /etc/rc.d/rc.inet1 file?
Have you disabled the Default GW entry?

Let me know
0
tariq030897Commented:
Kallisti,

Sorry I didn't get back to you earlier.  experts-exchange.com is kinda flaky, I tried getting on a couple of days ago and it was down...

the route delete/route add combo didn't work.

Here's the output of route:

[root@fnord:/var/log]# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
198.178.203.14  0.0.0.0         255.255.255.255 UH    0      0        0 ppp0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         198.178.203.14  0.0.0.0         UG    0      0        0 ppp0
[root@fnord:/var/log]# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
198.178.203.14  *               255.255.255.255 UH    0      0        0 ppp0
127.0.0.0       *               255.0.0.0       U     0      0        0 lo
default         198.178.203.14  0.0.0.0         UG    0      0        0 ppp0

I am at your mercy...

Thanx
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.