Solved

Problem with a ethernet card...

Posted on 1997-04-12
10
221 Views
Last Modified: 2010-03-18
I have a pentium-100 pc with 24meg RAM, a CD-ROM, an S3-Trio64+ display adapter with 2megs, and a SB16PnP.  I also have a Linksys EN-2420Px ethernet card.  Everything works just fine under win95 and there are no resource conflicts.  I have recently tried to install Red Hat 4.1 using NFS and it will not use my network card on any of the specified drivers.  It would not auto-detect and I even tried to tell each driver which io and irq to use.  The card uses standard NE2000 drivers under win95.  I then went to install Red Hat 4.0 from CD and to see if I could set up any cards manually.  This hasn't worked either.  If someone could tell me where a driver is or how I can write my own I would be grateful.  I do have moderate C/C++ ability.
0
Comment
Question by:Aquarius
  • 3
  • 2
  • 2
  • +3
10 Comments
 
LVL 4

Expert Comment

by:jlms
ID: 1584348
How did you tell Linux to detect the card?
0
 

Author Comment

by:Aquarius
ID: 1584349
I used netconfig and told it what io port and irq to look for...
0
 
LVL 4

Expert Comment

by:jlms
ID: 1584350
What was the answer to the command?
0
 
LVL 1

Expert Comment

by:t2pp
ID: 1584351
A couple of quick things to determine where you are... 1) does dmesg show the eth0 device? 2) have you used ifconfig? and 3) has your kernel got network card support?
0
 
LVL 4

Expert Comment

by:jlms
ID: 1584352
Is the card a Plug and Play device?
0
Free camera licenses with purchase of My Cloud NAS

Milestone Arcus software is compatible with thousands of industry-leading cameras for added flexibility. Upon installation on your My Cloud NAS, you will receive two (2) camera licenses already enabled in the software. And for a limited time, get additional camera licenses FREE.

 

Author Comment

by:Aquarius
ID: 1584353
Adjusted points to 150
0
 
LVL 2

Expert Comment

by:jprohart
ID: 1584354
trry to boot with "your_image ether=irq,ioaddress,eth0" at the boot prompt. Linux don't probe certain adresses at the boot, so you do have to tell it where to find your card. Be sure you have ne2000 support in your kernel.

Bye
0
 
LVL 2

Expert Comment

by:jprohart
ID: 1584355
trry to boot with "your_image ether=irq,ioaddress,eth0" at the boot prompt. Linux don't probe certain adresses at the boot, so you do have to tell it where to find your card. Be sure you have ne2000 support in your kernel.

Bye
0
 
LVL 4

Accepted Solution

by:
unicorntech earned 150 total points
ID: 1584356
Make sure that you are using the correct network support when you compile the kernel. Another thing to check is whether you are using a mouse as sometimes the irq for the mouse and ethernet card are set to the same irq (ie 3 or 4) and sometimes causes Linux to not detect the network card. Try changing the ethernet card irq with the driver disk and then rebooting linux.
0
 

Expert Comment

by:terabyte
ID: 1584357
Dear friend,

I had exactly this problem and I solve it in this way:
   
1) Edit your /usr/linux/src/net/driver/ne.c and look for       "wordlen" in it. One of that is an "if" statement that       check wether wordlen=2 or not. Just add this line befor       thats line:      wordlen=2;

2) After step 1, You must lokking for "NEXXX" statement. Exactly like step 1, There is a conditional expresion which checks that wether NEXXX is true or not. Add this line befor it:
 NEXXX=1;
3) Edit /etc/rc.d/rc.modules and search for "modprobe ne". After finding , uncomment it and give this parameter to it:
irq=0xxxx io=0xxxx   . Note that one of these parameters is essential (irq) and if you give that, it is eonugh.
4) After it, You must type: "make modules" and then
"make modules_install" and in the edn, "make zlilo". and reboot.

Be happy!
Terabyte@emirates.net.ae
---Ghanbari


0

Featured Post

Zoho SalesIQ

Hassle-free live chat software re-imagined for business growth. 2 users, always free.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
In this video I am going to show you how to back up and restore Office 365 mailboxes using CodeTwo Backup for Office 365. Learn more about the tool used in this video here: http://www.codetwo.com/backup-for-office-365/ (http://www.codetwo.com/ba…
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now