Adaptec 1542/Seagate ST-11200N

Having difficulty getting my Adaptec 1540CF/1542CF and my seagate ST11200N to talk with one another.  When I run the ctrl-A to run the setup sw and run test host adapter, I get the following error:

"Buffer miscompare!!!  Physical address 030B9Ah Offset: 35h"

It sounds like the hard drive is spinning up when I power on.  But then things get stuck at that "Press Ctrl-A" for a few minutes before things move on and it requests a floppy disk with system.  The red light on the adapter and the green light on the drive blink in unison every second or so.

The scsi cable has three connectors on it.  The scsi cable is connected to the internal connector (not the fat one on the back).  I've tried putting the HD on the middle one and on the end.  I've tried changing the terminator power settings on the drive to options A, B, C.  I've tried setting the drive to SCSI 1, 2, 4.  Switch 5 on the adaptec is set to On (disable floppy) as I am using the IDE controller for the floppy disk.  All other switches are off.  I've tried variing the i/o port and the bios address.  Tho perhaps not every permutation of those (6 x 6 = 36!)  I'm stuck!  
LVL 1
mmedwidAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

billogleCommented:
The drive and the controller both need to be terminated. Where the drive goes on the cable deosn't matter.  The Adaptec should be set to Scsi ID 7.  If you are booting off of a IDE and are intending to use te SCSI as drive d: make sure the Adaptec is not using the same memory address or IRQ as the IDE controller. If you are not using an IDE drive disable the controller and Set the Seagate HD ID to 0 and the bios HD c: selection to none.

If you need  additional help, email me your dirves (C,D,E etc) and your autoexec.bat and config.sys.

bill_ogle@reborn.com
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mmedwidAuthor Commented:
Thanks Billogle.  
0
brujCommented:
A buffer miscompare is cuased by the DMA either not being available, or, that the DMA trans rate is set to high. These are really the only 2 cuases, as the test is to test for DMA transfer.

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware

From novice to tech pro — start learning today.