Modeless dialog and accelerators

I've got some modeless dialogs inside a CFormView (like a CPropertyPage/Sheet). The accelerators don't work when focus is on one of the dialogs.
Any idea how I can make them work?
roarAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rajesh032097Commented:
Hi,
Try the following:
Set the "control" property for each of your dialog which you are using inside the CFormView. This property is available in the "More Styles" tab of the dialog properties in the VC++ dialog editor.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
roarAuthor Commented:
I really expected that to work, given the description of the control property in the online help. I applied the control property to the dialogs, but unfortunately I still got the same problem. If you made it work, can you give me some details on what you did?
0
rajesh032097Commented:
Can you elaborate on how exactly you are using the form view? I had the same problem and got solved by setting the "control" property. One more thing which also worked with me is setting "control parent" property in "extended styles" tab. But if your dialogs are derived from CPropertyPage, then this won't work since Property pages donot yet support dialog templates with extended styles.  
Hope this works.
0
rajesh032097Commented:
Hi again,
Please also refer to "using accelerators in modeless dialogs" article in MFC knowledge base.
If you have any problems with it, get back to me.
0
roarAuthor Commented:
I added a PreTranslateMessage as described in the article, and it worked beatifully. Thanks.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
System Programming

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.