Solved

Module Problem

Posted on 1997-04-23
3
270 Views
Last Modified: 2013-12-15
I just installed Slackware 3.2 using the kernel 2.0.29. After configuring the the kernel I built it using the following commands.

make mrproper
make config
make depend
make clean
make zImage
make modules
make modules_install
depmod -a
make zlilo

After rebooting I get the following errors.

***Unresolved symbols in module raid.o
                                                    ncpfs.o
                                                    appletalk.o
                                                    ipx.o
                                                    misc.o
                                                    dlci.o
                                                    linear.o

Why is the kernel trying to use these modules and how do I resolve the unresolved symbols???
0
Comment
Question by:mattge
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 1

Accepted Solution

by:
ggeens earned 200 total points
ID: 1627235
Do you have the option set?
If so, you have to do the make modules and modules_install /after/ the make zlilo .
make zlilo changes the internal version numbers. If you don't re-make your modules after that, they will have an incorrect number in them.
Alternatively, you can recompile everything without the CONFIG_MODVERSIONS.
0
 

Author Comment

by:mattge
ID: 1627236
Should I reinstall before remaking then. I just tryed to make modules and make modules_install and still get the same problem.

I do have it set to use modules if that is what you meant. I also have it set not to use the CONFIG_MODVERSIONS.

Matt G
0
 
LVL 1

Expert Comment

by:ggeens
ID: 1627237
I suspect that these modules were installed by Slackware itself.
You didn't compile all of them in your own kernel, but these files are still in your /lib/modules/2.0.29 hierarchy.
When Slackware boots up, it does a depmod -a . It finds some of the modules, but sees that they don't match your new kernel.
Remove all files from the /lib/modules/2.0.29 hierarchy and reinstall (Same procedure as you originally did, but replace the `make zImage' by `make zlilo').
(Note, to be on the safe side, make a copy of them and keep a rescue disk handy.)
Also, Check the /etc/rc.d/rc.modules file to make sure no unwanted modules are loaded.
0

Featured Post

Back Up Your Microsoft Windows Server®

Back up all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
Fine Tune your automatic Updates for Ubuntu / Debian
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question