Solved

SunOs and Solaris NFS mount problem

Posted on 1997-04-25
3
1,586 Views
Last Modified: 2013-12-16
I'm trying to remount a directory from a SunOs 4.1.3 machine
onto a machine running Solaris 2.5.1
I used to be mounted fine, but since then I'm encountering the following error:
mount xxx.xxx.xxx.xxx:/home/public /public
nfs mount: xxx.xxx.xxx.xxx:/home/public: access denied

I've already tried running exportfs -a and ensured that
the client's ip is present in the /etc/exports file

Any help ?
0
Comment
Question by:chrisvo
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 2

Expert Comment

by:pxh
ID: 1812082
sounds like a easy thing to do. I have exactly the same done here. we would need to look more careful into details and also I do not really understand how to understand

"...used to be mounted fine, but since then I'm encountering the following ..."

Do you mean you could ever mount it that very way? What is "since then"?

For now I can only advice you to enter "exportfs" (without options) on the SunOS machine and also let me know the output. Also inform me how you presicely tried to do the mounting on the Solaris system.

I notice one difference between your and my approach: I use hostnames instead of IP numbers. It is more comfortable, but I wouldn't think that it is resposible for your prob. until I lokked into it.

Peter

0
 
LVL 4

Accepted Solution

by:
jlms earned 50 total points
ID: 1812083
Solaris 2.5 (and I guess 2.5.1) start by default the automounter, this makes the directory /home not accesible (check the permissions and you will notice that they are 555 meaning nobody can write to it).

So follow this steps:
-Stop the automounter:
/etc/init.d/autofs stop
-Check that you can mount the remote disks.
-Change the name of the script that starts the automounter in /etc/rc2.d (I don't have the name now, but is something like Snnautofs where nn is a number of two digits, tha only thing you hvae to do is rename it so it does not begin with "S").

  Another option could be to configure the automounter to handle the directory you want to mount, but if it is the only one you need to sure you should not bother (unless you want to learn a little bit more of Solars :) ).
0
 
LVL 4

Expert Comment

by:jlms
ID: 1812084
If the automounter is really the problem, the advice to modify a /etc/rc2.d file may still not be the best, just imagine the automounter IS needed...

It is really better to comment out the line

/home           auto_home

in /etc/auto_master. Then type "automount" to make it reread the config and then also enter "umount /home"!

That should do the job on the Solaris 2.x system.

However, let's carefully read the question! Chrisvo is trying to mount to /public on the Solaris 2.5.1 system  and it should be irrelevant that he has a path /home/public on the SunOS 4.1.3 system.

I would also like to add that the automounter is not much more difficult to configure as the vfstab file and I would rather recommand to use it. However only if a manual mounting has been shown to work.

JMHO

Peter (pxh@mpe-garching.mpg.de)

0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

A metadevice consists of one or more devices (slices). It can be expanded by adding slices. Then, it can be grown to fill a larger space while the file system is in use. However, not all UNIX file systems (UFS) can be expanded this way. The conca…
I have been running these systems for a few years now and I am just very happy with them.   I just wanted to share the manual that I have created for upgrades and other things.  Oooh yes! FreeBSD makes me happy (as a server), no maintenance and I al…
This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.
In a previous video, we went over how to export a DynamoDB table into Amazon S3.  In this video, we show how to load the export from S3 into a DynamoDB table.

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question