[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

BDE Configuration

Posted on 1997-04-27
6
Medium Priority
?
279 Views
Last Modified: 2010-05-18
I have just completed a program that uses TQuery components to access data in a .db file. I can run it fine on my development machine but when I try to use the program on another machine after running my InstallShield install I get a "Table is read only" and the program will not update my database.

I kinda think that this is in the BDE configuration but don't really know. I set the BDE configuration in the setup (Installshield) to have the same alias name.

I am at a loss here. I cannot find anything that tells me why it will work on my machine but not on another.
0
Comment
Question by:jkb2
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 2

Expert Comment

by:javiertb
ID: 1335738
Did you try creating the new alias within the BDE and not when you use InstallShield?
0
 
LVL 1

Expert Comment

by:miv
ID: 1335739
Do you distribute the program on a CD-ROM ?
Is any of the db-files marked read-only (DOS attrib) ?
0
 
LVL 1

Author Comment

by:jkb2
ID: 1335740
Just Tried it, Didn't Work. Still Getting "Table is Read Only".

thanks
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 1

Author Comment

by:jkb2
ID: 1335741
This program was Distributed as a zip file. (No CDROM)

And it is not marked as read only via the Win95 attribute properties.


0
 

Expert Comment

by:ovj
ID: 1335742
Have you checked that there isn't a *.lck (lock) file. If so, remove it and it should work. Otherwise compare all other parameters in BDE setup for the DB driver you use with the values set on your development machine. Could be this.
0
 

Accepted Solution

by:
urih earned 300 total points
ID: 1335743
Try to check the RequestLive to TRUE.
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction The parallel port is a very commonly known port, it was widely used to connect a printer to the PC, if you look at the back of your computer, for those who don't have newer computers, there will be a port with 25 pins and a small print…
Introduction I have seen many questions in this Delphi topic area where queries in threads are needed or suggested. I know bumped into a similar need. This article will address some of the concepts when dealing with a multithreaded delphi database…
This course is ideal for IT System Administrators working with VMware vSphere and its associated products in their company infrastructure. This course teaches you how to install and maintain this virtualization technology to store data, prevent vuln…
In this video, Percona Director of Solution Engineering Jon Tobin discusses the function and features of Percona Server for MongoDB. How Percona can help Percona can help you determine if Percona Server for MongoDB is the right solution for …
Suggested Courses

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question