removing scroll bar from richedit control

How do I remove the automatic vertical scroll bar from a rich edit control  ? (the scroll bar  is automatically added when the number of lines exceeds the visible lines in the view ). I have tried modifying the window's style so that WS_VCSROLL is removed, but this does not solve this problem. I want to do this dynamically because there are certain places in the program where I do want a scroll bar to appear in the rich edit control.
pjnAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rajesh032097Commented:
Hi,
Try using CWnd function ShowScrollBar(). This function will hide or show the scrollbars.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
pjnAuthor Commented:
ShowScrollBar was nearly it but I get a big flicker where the toolbar was and then it was removed. My program uses the rich edit control as a log and hence this problem is really bad. If had tried you suggest with SetRedraw and LockWindowUpdate but no cigar. Any other ideas.
0
rajesh032097Commented:
Sorry,
I have no idea for that problem. May be if you could elaborate more on how exactly you are using the rich edit control, one can get the solution.
0
OWASP: Avoiding Hacker Tricks

Learn to build secure applications from the mindset of the hacker and avoid being exploited.

pjnAuthor Commented:
I am using the rich edit control to write continous logging information into. This is happening quite fast and evertime I add some text to the control which goes beyond the current depth the rich edit control automatically adds a vertical scrollbar. What I want to do is while sending information to the rich edit control is to disable the vertical scroll bar. It is very disconcerting seing the scrollbar recalculate its size everytime I add some text to it. Hopefully by removing the scrollbar, this will speed things up also. Then when I have finished adding the text to the control, I can reenable the scrollbar so the user can leaf back up through the log.
0
rajesh032097Commented:
Hi,
I cannot solve your problem.
Sorry.
0
pjnAuthor Commented:
I fixed the problem myself by adding the following to my Views class constructor

m_dwDefaultStyle &= ~ WS_VSCROLL;

Thanks all the same for the input
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
System Programming

From novice to tech pro — start learning today.