Sendmail overriding Eudora return address

I'm using Solaris 2.5.1 and running sendmail 8.8.4.
 When I send an email using Eudora, sendmail replaces what I have in my
return address configuration with whatever is in the hosts file that
sendmail is running on.  For instance, if I put ccsi.com first in the hosts
file, and if I have infinity.ccsi.com in my Eudora (or MS internet mail),
after I send an email the return address is replaced with teklord@ccsi.com.
 If I change the hosts file to have infinity.ccsi.com first, then it is
changed to teklord@infinity.ccsi.com, even if I have teklord@ccsi.com in
the Eudora return address.  I really need help so that it ignores the hosts
file and just uses what ever is in the return address field of the
respective programs.   Thanks in advance.:
teklordAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

fsgreenCommented:
sounds like you have masquerading set in your solaris sendmail.cf file.  look for a line that starts with:

  CM...

if there's anything after the "CM", erase it (but leave the CM).

restart sendmail.

i THINK that's the only place it's set

let me know if it works.
0
teklordAuthor Commented:
I don't have masquerading on.  This is the line for my sendmail.cf:

# class L: names that should be delivered locally, even if we have a relay
# class E: names that should be exposed as from this host, even if we
masquerade # class M: domains that should be converted to $M
#CL root
CE root

# dequoting map
Kdequote dequote

# who I masquerade as (null for no masquerading) (see also $=M)
#DM
                 
I tried replacing the CE root with just CM, to no avail.  Thanks.

Any other ideas?
0
fsgreenCommented:
i'm pretty sure to turn off masquerading, you need to have DM (sorry - i had CM in my first answer) defined to null:


# class L: names that should be delivered locally, even if we have a relay
# class E: names that should be exposed as from this host, even if we masquerade
# class M: domains that should be converted to $M
#CL root
CE root

# dequoting map
Kdequote dequote

# who I masquerade as (null for no masquerading) (see also $=M)
DM

this is an excerpt from my sendmail.cf file.  eudora is our user mail agent (both mac and pc, lite and pro) and it keeps the eudora set return address.

to be paranoid, i just monkeyed with my eudora settings and verified that it kept the eudora return address.

                         doug.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.