Solved

NIS+ and YP compatibility

Posted on 1997-05-05
2
243 Views
Last Modified: 2013-12-16

Hi,
      I am tring to set up a Sol2.5.1 machine, to be both a YP client
      to one domain, eso1 and a NIS+ master of another domain,
      secure.eso.org. All works well except yp and nis+ both look
      in the same place for their domain name, the value returned
      from sysinfo. This screws one or the other, dependant on whats
      been set in /etc/defaultdomain. And if this has been changed after
      say nis+ has been set, for yp to use, then nis+ will fail.
      
      Is it possible to change where yp or nis+ look for this info.
      Is there any source available for this so I can change it?

      Ideas?
      
Kind regards,

Simon.


--

------------------------------------------------------------------
Simon J Loewenthal      -       ESO Helpdesk
sloewent@eso.org      -      European Southern Observatory (ESO)
www.eso.org/it            -      Karl-Schwarzschild-Strasse 2
++49-89-320-06333      -       D-85748 Garching bei Muenchen
                  -      Germany
------------------------------------------------------------------
0
Comment
Question by:sloewent
2 Comments
 

Author Comment

by:sloewent
ID: 1812130
Adjusted points to 150
0
 
LVL 2

Accepted Solution

by:
pxh earned 150 total points
ID: 1812131
Well, I have some ideas but never tried it. If it works fine, if no just reject, OK?

Let's assume for simplcity that you want the yp use a different domain from what is entered in /etc/defaultdomain. Go to /var/yp or where wever you installed the yp config files. Look into the Makefile there is a line

DOM = `domainname`

so you can edit this line and specify the domainname you want there.

Next look into the /var/yp subdirectories, you will find directories named like you yp-domain there. Try to rename them. E.g. our domain is xmm.mpg.de and there exist a xmm.mpg.de directory directly on /var/yp and one in /var/yp/binding.

Next go to /etc/init.d and look into the file yp. Also there the domainname is taken queried (domain=`domainname`). Again, you may have to change this.

There is nothing else I can think to do. But as I said, I am a bit guessing, since I never tried this.

Good luck,

Peter (pxh@mpe-garching.mpg.de)

0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Attention: This article will no longer be maintained. If you have any questions, please feel free to mail me. jgh@FreeBSD.org Please see http://www.freebsd.org/doc/en_US.ISO8859-1/articles/freebsd-update-server/ for the updated article. It is avail…
FreeBSD on EC2 FreeBSD (https://www.freebsd.org) is a robust Unix-like operating system that has been around for many years. FreeBSD is available on Amazon EC2 through Amazon Machine Images (AMIs) provided by FreeBSD developer and security office…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…

862 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now