• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 482
  • Last Modified:

Linux Routing

I have just set up Linux with what seems to be all the necessary items ie(route, hosts.conf, etc.) My problem though is that although I can ping myself using loopback, I cannot see anyone on the network.   I get an error  "Unable to connect to remote host: No route  to host.  I would like to know how to cure this problem.
0
ejs
Asked:
ejs
1 Solution
 
mlevCommented:
Check 'route' - does it show everything you need?

If you have a PPP connection, you need a default route:
route add -net default <peer address>
0
 
xtermCommented:
Do you have support compiled for your ethernet card?  does it
detect it at boot time?
Do you have a gateway configured?  route add default gw <IP addy>
paste the results of "netstat -nr" after adding your gateway if
you're still having problems, and let us take a look

0
 
pc012197Commented:
Pinging yourself using loopback is net very helpful. Try to ping yourself with your IP-address. If it works, you have a routing problem, if it doesn't you have an ifconfig problem.

0
 
duxCommented:
If you network card works correctly, add a route to your network like this:

route add - net your_net

where your net is your network address. (ex. for a C class: 193.226.6.0)
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now