Complete network configuration

Hello, I need help.
The computer I use at my job is connected directly to Internet and I want to connect it to internet with Linux. I have compiled my kernel many times and it doesn't recognize my ethernet card. I have tried to force it with my lilo.conf file with the line append ...... but it has not worked (I dont know with address to put (I have tried to guess)). Well, the fact is that my IP is 204.95.128.204 my gateway is my router  it's 204.95.128.14 and I dont know what to do with my ethernet card. I have run netconfig and filled all the information? What do I have to do now?. I
My kernel support NE2000, my kernel is 2.0.8., My linux distribution is Slackware 3.0

Thanks
LVL 1
aacostaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

xtermCommented:
The key to setting the ethernet card up properly is getting it
WORKING first.  Use the DOS-based config utility that came with
your ethernet card to find out which base IO and IRQ it is using.
Then you can pass those parameters to LILO if necessary.
(eg. linux ether="0x300,10")  Watch your boot sequence closely -
until your card is DETECTED on bootup, don't bother with your
gateways & DNS etc.  Then when you get it going, just add your
gateway to your routing table (route add default gw <IP>) and
add your name servers to /etc/resolv.conf (nameserver <IP>) and
you should be in business.  Oh.. and be sure to compile support
for NE2000 compatibles if you haven't already (I was taking that
part for granted...)
0
aacostaAuthor Commented:
The problem is that when I take the ethernet card configuration from DOS/WIN95 and I put it into my lilo.conf file in the bootup appear "Network is unreachable"
0
xtermCommented:
I know I know.. IS the card recognized at bootup?
DID you or did you not compile support for NE2000 cards?
These are important questions.  Network is Unreachable
could mean a bunch of things.
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

aacostaAuthor Commented:
Yes, my kernel support NE2000 card (I already mounted a network at my house), I am using the same kernel and ethernet card at my job and at my house.
If I don't put anything al the lilo.conf file my kernel doesn't reconize my card at the bootup, (at my house the kernel does).
But, I put at my lilo.conf the address 0x280 and IRQ 11, when I bootup it look like it's recognize (something like NE*000 found 0x280 using IRQ 11), but I can't ping any computer (the computer doesn't do anything nor give me any error). After I tried to ping a computer if I see my bootup (with dmesg) there are a couples of error with eth0. What's wrong?. The card works perfectly under WIN 95.
0
xtermCommented:
paste everything that you can from dmesg here so I can take a
look.  Also do "netstat -nr" and paste the results of that.
Also, do "cat /proc/interrupts" and see if "NE2000" appears.

Then we'll go from there.
0
aacostaAuthor Commented:
Yes, my ethernet card appear here: cat /proc/interrupts if I put it into my lilo.conf.
I'm gonna check my dmesg and to see what happend if I "netstat -nr" (I don't know what is this).

0
aacostaAuthor Commented:
Hello, this is my dmesg. I hope it can help you. I'm sorry for the address I gave you before the real address are 0x240 using IRQ 11.
Remenber when I try to ping another computer at the end of my dmesg appear an error on eth0
I do can ping myself.
Thanks for all your interest

Console: 16 point font, 400 scans
Console: colour VGA+ 80x25, 1 virtual console (max 63)
pcibios_init : BIOS32 Service Directory structure at 0x000fadc0
pcibios_init : BIOS32 Service Directory entry at 0xfb230
pcibios_init : PCI BIOS revision 2.10 entry at 0xfb260
Probing PCI hardware.
Warning : Unknown PCI device (8086:7030).  Please read include/linux/pci.h
Calibrating delay loop.. ok - 39.94 BogoMIPS
Memory: 30968k/32768k available (692k kernel code, 384k reserved, 724k data)
Swansea University Computer Society NET3.035 for Linux 2.0
NET3: Unix domain sockets 0.12 for Linux NET3.035.
Swansea University Computer Society TCP/IP for NET3.034
IP Protocols: ICMP, UDP, TCP
Swansea University Computer Society IPX 0.34 for NET3.035
IPX Portions Copyright (c) 1995 Caldera, Inc.
Checking 386/387 coupling... Ok, fpu using exception 16 error reporting.
Checking 'hlt' instruction... Ok.
Linux version 2.0.8 (root@desk2) (gcc version 2.7.0) #1 Tue May 6 12:26:20 GMT-0400 1997
Serial driver version 4.13 with no serial options enabled
tty00 at 0x03f8 (irq = 4) is a 16550A
tty01 at 0x02f8 (irq = 3) is a 16550A
Ramdisk driver initialized : 16 ramdisks of 0K size
ide: 430FX (Triton) on PCI bus 0 function 57
    ide0: BM-DMA at 0x9000-0x9007
    ide0 timing: (0xa107) sample_CLKs=3, recovery_CLKs=3
         master: fastDMA=on  PreFetch=on  IORDY=on  fastPIO=on
         slave : fastDMA=off PreFetch=off IORDY=off fastPIO=off
    ide1: BM-DMA at 0x9008-0x900f
    ide1 timing: (0x8000) sample_CLKs=5, recovery_CLKs=4
         master: fastDMA=off PreFetch=off IORDY=off fastPIO=off
         slave : fastDMA=off PreFetch=off IORDY=off fastPIO=off
Floppy drive(s): fd0 is 1.44M
Started kswapd v 1.4.2.2
FDC 0 is an 8272A
md driver 0.35 MAX_MD_DEV=4, MAX_REAL=8
linear personality registered
raid0 personality registered
Equalizer1996: $Revision: 1.2 $ $Date: 1996/04/11 17:51:52 $ Simon Janes (simon@ncm.com)
PPP: version 2.2.0 (dynamic channel allocation)
TCP compression code copyright 1989 Regents of the University of California
PPP Dynamic channel allocation code copyright 1995 Caldera, Inc.
PPP line discipline registered.
SLIP: version 0.8.4-NET3.019-NEWTTY (dynamic channels, max=256).
CSLIP: code copyright 1989 Regents of the University of California.
NET3 PLIP version 2.2 gniibe@mri.co.jp
plip1: Parallel port at 0x378, using assigned IRQ 7.
ne.c:v1.10 9/23/94 Donald Becker (becker@cesdis.gsfc.nasa.gov)
NE*000 ethercard probe at 0x240: 00 00 21 95 53 42
eth0: NE2000 found at 0x240, using IRQ 11.
Partition check:
 hda:  hda: WDC AC21200H, 1222MB w/128KB Cache, CHS=621/64/63, MaxMult=16
 hda1 hda2 hda3
JAVA Binary support v1.01 for Linux 1.3.98 (C)1996 Brian A. Lantz
VFS: Mounted root (ext2 filesystem) readonly.
Adding Swap: 34268k swap-space
net_interrupt(): irq 11 for unknown device.
fcntl_setlk() called by process 76 (lpd) with broken flock() emulation


0
aacostaAuthor Commented:
I have not solved my problem
0
jprohartCommented:
if your machine have a pci bus, try to lock irq 11 for isa bus (network cards don't like irq sharing) or change your card configuration to irq 5 if available (no sound card). You must verifiy that your card don't use shared memory (like ne2100 compatibles) , i think linux don't like it.
It looks like a irq sharing problem.

good luck.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
aacostaAuthor Commented:
I gonna answer you on monday. Thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.