[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

INIT: error loading initresource

Posted on 1997-05-07
12
Medium Priority
?
302 Views
Last Modified: 2013-12-15
My linux setup has been working perfectly for around a year now, but a few weeks ago I started getting the problem that whenever I change runlevels (including when I shut down in other words) I get about 10000 messages saying
INIT: error loading initresource

the /var/log/messages file confirms the fact that I get around 10000 of these. (The amount is never the same)

I've searched long and hard through my /etc/inittab for errors, and gone through all the files in /etc/rc.d

Has anybody ever experienced this and found the answer? For a good answer you can score a cool 400 points....
0
Comment
Question by:gysbert1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 6
12 Comments
 
LVL 1

Expert Comment

by:ggeens
ID: 1627427
Did you change anything in your setup when it started?
Did you have a disk crash?
Did you had to do a forced reboot?

0
 
LVL 2

Author Comment

by:gysbert1
ID: 1627428
I did not purposefully change anything, and I didn't have a disk crash. I did have to do a forced reboot once or twice though, but it never detected anything wrong with the inodes on startup. It just ran fsck on my drives.
0
 
LVL 1

Expert Comment

by:ggeens
ID: 1627429
Which version of init are you using? And which kernel and distribution?
0
Moving data to the cloud? Find out if you’re ready

Before moving to the cloud, it is important to carefully define your db needs, plan for the migration & understand prod. environment. This wp explains how to define what you need from a cloud provider, plan for the migration & what putting a cloud solution into practice entails.

 
LVL 2

Author Comment

by:gysbert1
ID: 1627430
Distribution: Redhat 3.03
Kernel: 2.0.25
Init is the same one I originally got with this distribution. Not sure offhand what its version number is. I have tried with kernels ranging from 1.2.13, 2.0.0, 2.0.7 to 2.0.25 since I still had zImages of all those, but it doesn't make any difference.
0
 
LVL 1

Expert Comment

by:ggeens
ID: 1627431
Linux 2.0 needs sysvinit version 2.64.
To find out your init version, use (taken from /usr/src/linux/Documentation/Changes):
cat /proc/`cat /var/run/syslog.pid`/environ|strings|awk '$1 ~ /INIT_VERSION/ {print}'
If you get 2.59 or lower, you should upgrade. (Grab the RPM from RedHat or one of its mirrors.)
But that would not explain why you get the errors on a 1.2.13 kernel.
0
 
LVL 2

Author Comment

by:gysbert1
ID: 1627432
I have got sysinit version 2.64. I think its definately something that went wrong at some point. When I upgraded to kernel 2 for the first time, I downloaded an upgrade rpm package which upgraded a whole bunch of files on my computer. That was quite long ago though, and the computer worked fine for a long time after that....
0
 
LVL 1

Expert Comment

by:ggeens
ID: 1627433
I guess your /sbin/init has become corrupted by the disk crash. If this is the case, reinstalling init will solve your problem.
If it doesn't, I don't know what's wrong.
0
 
LVL 2

Author Comment

by:gysbert1
ID: 1627434
Been there, Done that, no luck.

Thanx for trying anyway ...

Any other ideas ?
0
 
LVL 1

Expert Comment

by:ggeens
ID: 1627435
/dev/initctl or /var/run/utmp corrupt?
These should repair themselves after a reboot.
I'm clueless.
0
 
LVL 2

Author Comment

by:gysbert1
ID: 1627436
ggeens: Just send me an answer, any answer. One of your comments did it for me (the  init version) For some reason I had version 2.58 and version 2.64 on the machine, and it was using 2.58 because it was in the /sbin directory. I don't know why 2.64 wasn't there though....
0
 
LVL 1

Accepted Solution

by:
ggeens earned 200 total points
ID: 1627437
You say you have init 2.64 on your system, but not as /sbin/init
I guess you know where it is. (/sbin/init.new maybe?)
First of all, check that /sbin/reboot and /sbin/halt have the correct version. (They should be links to the same file anyway.)
Type:
rm /sbin/init
cp /sbin/init.new /sbin/init

(Don't worry, your system will keep working.)
Now reboot. Linux will start the correct init.
The next fsck will complain about deleted inodes with zero dtime, but you can ignore that.
0
 
LVL 2

Author Comment

by:gysbert1
ID: 1627438
Thanks, but as soon as I saw what the problem was, I fixed all offending files. I think at some stage an rpm must have stuffed or something, or I was dreaming when I installed it. Thanks for the help, my linux is now nice again :)
0

Featured Post

[Webinar] Lessons on Recovering from Petya

Skyport is working hard to help customers recover from recent attacks, like the Petya worm. This work has brought to light some important lessons. New malware attacks like this can take down your entire environment. Learn from others mistakes on how to prevent Petya like worms.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Using 'screen' for session sharing, The Simple Edition Step 1: user starts session with command: screen Step 2: other user (logged in with same user account) connects with command: screen -x Done. Both users are connected to the same CLI sessio…
The purpose of this article is to demonstrate how we can use conditional statements using Python.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Suggested Courses

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question