We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now

x

INIT: error loading initresource

gysbert1
gysbert1 asked
on
Medium Priority
317 Views
Last Modified: 2013-12-15
My linux setup has been working perfectly for around a year now, but a few weeks ago I started getting the problem that whenever I change runlevels (including when I shut down in other words) I get about 10000 messages saying
INIT: error loading initresource

the /var/log/messages file confirms the fact that I get around 10000 of these. (The amount is never the same)

I've searched long and hard through my /etc/inittab for errors, and gone through all the files in /etc/rc.d

Has anybody ever experienced this and found the answer? For a good answer you can score a cool 400 points....
Comment
Watch Question

Commented:
Did you change anything in your setup when it started?
Did you have a disk crash?
Did you had to do a forced reboot?

Author

Commented:
I did not purposefully change anything, and I didn't have a disk crash. I did have to do a forced reboot once or twice though, but it never detected anything wrong with the inodes on startup. It just ran fsck on my drives.

Commented:
Which version of init are you using? And which kernel and distribution?

Author

Commented:
Distribution: Redhat 3.03
Kernel: 2.0.25
Init is the same one I originally got with this distribution. Not sure offhand what its version number is. I have tried with kernels ranging from 1.2.13, 2.0.0, 2.0.7 to 2.0.25 since I still had zImages of all those, but it doesn't make any difference.

Commented:
Linux 2.0 needs sysvinit version 2.64.
To find out your init version, use (taken from /usr/src/linux/Documentation/Changes):
cat /proc/`cat /var/run/syslog.pid`/environ|strings|awk '$1 ~ /INIT_VERSION/ {print}'
If you get 2.59 or lower, you should upgrade. (Grab the RPM from RedHat or one of its mirrors.)
But that would not explain why you get the errors on a 1.2.13 kernel.

Author

Commented:
I have got sysinit version 2.64. I think its definately something that went wrong at some point. When I upgraded to kernel 2 for the first time, I downloaded an upgrade rpm package which upgraded a whole bunch of files on my computer. That was quite long ago though, and the computer worked fine for a long time after that....

Commented:
I guess your /sbin/init has become corrupted by the disk crash. If this is the case, reinstalling init will solve your problem.
If it doesn't, I don't know what's wrong.

Author

Commented:
Been there, Done that, no luck.

Thanx for trying anyway ...

Any other ideas ?

Commented:
/dev/initctl or /var/run/utmp corrupt?
These should repair themselves after a reboot.
I'm clueless.

Author

Commented:
ggeens: Just send me an answer, any answer. One of your comments did it for me (the  init version) For some reason I had version 2.58 and version 2.64 on the machine, and it was using 2.58 because it was in the /sbin directory. I don't know why 2.64 wasn't there though....
Commented:
You say you have init 2.64 on your system, but not as /sbin/init
I guess you know where it is. (/sbin/init.new maybe?)
First of all, check that /sbin/reboot and /sbin/halt have the correct version. (They should be links to the same file anyway.)
Type:
rm /sbin/init
cp /sbin/init.new /sbin/init

(Don't worry, your system will keep working.)
Now reboot. Linux will start the correct init.
The next fsck will complain about deleted inodes with zero dtime, but you can ignore that.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
Thanks, but as soon as I saw what the problem was, I fixed all offending files. I think at some stage an rpm must have stuffed or something, or I was dreaming when I installed it. Thanks for the help, my linux is now nice again :)
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.