[Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 301
  • Last Modified:

DOS4GW problem.

I've got the problem with DOS4GW dos extender for Watcom C.
I would like to make it not to allocate the whole available
extended memory. I need it to spawn another DOS4GW program
from main module.
0
lenin
Asked:
lenin
1 Solution
 
icdCommented:
I suggest you look at the functions available for TSRs written with DOS4GW since these programs must solve a similar problem.

I can't give you a direct answer since I only have the manual for the 16 bit version.

If this does not help then just reject my answer.
0
 
eljaincCommented:
I am new to the DOS4GW DOS extender environment, but it seems to me that you
can increase/limit the amount of memory that a program using the extender will use.
This is done by setting by using the DOS4GVM environment variable:

SET DOS4GVM=virtualsize#(memsize)

The "memsize" will be the amount of RAM to limit (in KB)

Thus, if you wanted to limit the amount of memory to 8 Megabytes, you would do something
like:

SET DOS4GVM=virtualsize#8000

Hope this helps
0
 
tdxhCommented:
If you need it to spawn another DOS4GW program
from main module, you must remember to set the __minreal to
set aside some DOS memory. The __minreal is a public variable,
you can set it as:
    unsigned __near __minreal = 100 * 1024;
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now