Wordart 2.0 will not launch??

I've had this problem off and on for months and no amount of research has helped and even MS can't pinpoint the reason for this "bug". I can't seem to be able to launch Ms-Wordart 2.0 in Publisher 2.0 or Word 6.0 or Excel 5.0 all of a sudden?

I've tried reinstallations of all the apps including a 2nd WIN311 directory and all have led to zilch! I would like to once & for all work out why this has happened and what on earth causes it!

I have already tried the set-up procedures and re-installation of Wordart 2.0 via Publisher and Word and nothing works!

Appreciate any help I can get on this as I use WordArt 2.0 quite a bit in my presentations.

Thanks to one and all!

Sincerely,
IMRAN C.
imran050997Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jluCommented:
I cant help you finding out why it suddently disapear, but if you have made a standard office installation, this feature wount be enabled. You have to make special installation and then choose this option. I am working on a danish version, so I cant remember field name in installation, but its one of the generel to use for hole msoffice.
0
imran050997Author Commented:
Edited text of question
0
imran050997Author Commented:
I don't understand the solution offered?
0
CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

nyljaCommented:
Start Regedit (File-Run)
Import *.dat in the MSOffice-directory.

0
imran050997Author Commented:
I am not running the Ms-Office Suite instead they are all separate applications eg. Ms-Word 6.0, Ms-Publisher 2.0, Ms-Excel 5.0, Ms-Access 2.0. So I do not have an Ms-Office directory. Please advise.
0
nyljaCommented:
Then there should be *.reg files in at least the winword directory.
0
billogleCommented:
Do you an not enough memory error?
0
imran050997Author Commented:
No, I do not get a "Not enough memory Error".

Yes, I do have the *.reg files from the Winword, Publisher, Wordart directories and I have already registered them respectively in the reg.dat file and I'm still getting the error with Wordart so that doesn't seem to be the solution either unfortunately. I will probably need to contact the trouble-shooting dept at Microsoft Australia as now one can find a proper reason or answer. Thanks anyway!
0
imran050997Author Commented:
BTW, do you realise that both Ms-Word 6.0 and Ms-Publisher install Ms-Wordart 2.0????
0
billogleCommented:
Exactly what is the error mesage your reveive?  How much memory do you have installed?  How many %wise resourses do you have free? This can be found by clicking on help and then on about.
0
billogleCommented:
Often the pubole.dll becomes corrupted (usually you will get an error message in this case).  If you look on your installation media for a file pubole.dl_ and check the date.  If the one in Word and the one in Publisher are different, install the one with the latest date again so that the most current date will be the one installed.
0
imran050997Author Commented:
The error message I get when I try to launch Wordart in Word 6.0, Publisher 2.0 or Excel 5.0 is:-

"The server application source file or item cannot be found. Make sure the application is properly installed and that it has not been deleted, modified or renamed."

I know for a fact that it is registered in the reg.dat file as it is there and I have tried fixes recommended by Microsoft which sadly does NOT work! I will check on the pubole.dll file and see if that is the cause.

I am using 8Mb Ram and have been for over 3 years without a single "low memory" problem. Have been using Wordart 2.0 without a hitch since 1995! There must be a corrupted file somewhere in the Windows dir. but I don't know which one?
0
billogleCommented:
For some reason Windows thinks that you are attempting to connect to a network server.

If you will email your autoexec,bat. , config.sys, Windows system.ini and win.ini to me at bill_ogle@reborn.com, I'll try to help you.
0
imran050997Author Commented:
I doubt that Windows thinks that I'm attempting to connect to a network server. This problem has happened previously and fixed through a complete re-installation of everything on the machine however that didn't work this time and I need to find out what specifically is causing this. I thought there may have been other people who have had a similar problem on this Exchange however so far I can't find anyone else with that dilemma?

Server application has nothing to do with networking.

Thanks for your help and I'll try and send you those ini files.

0
billogleCommented:
Server application has nothing to do with networking.  I disagree with this.

Have you tried using an uninstaller, such as Cleansweep, or Uninstaller3 to remove the offending applicatons before reinstalling?

There have been others with similar problems, but most have been solved with use of theird party utilities that return memory from "leakers" -- WordArt, Excel, and Word being 3 of the worst offenders.  Since you have not had encounteed memory errors, I did not consider this.  Have you compared the date of the pubole.dl_ from thedistributions disks of Word and Publisher?
0
imran050997Author Commented:
Have sent you my *.INI files and the autoexec.bat & config.sys for your expert perusal. I can't get into my Word 6.0 disks because they are archived as word2.cab word3.cab word4.cab in each diskette?

My only other option is to install a 2nd Win311 directory, reinstall PUB2 and see if that works?
0
imran050997Author Commented:
Do you know which files Wordart2 uses in the Windows dir and Windows/System dir? If I can locate the offending file, I could isolate it for the future?

Thanks again for your time & effort Bill !
0
c827451Commented:
I can reproduce this problem (and solve it) in different ways :
1) Fysically delete (or damage) the wordart2.exe
2) Using regedit /v to mess things up

I think I can solve your problem, but then I need more info
1) The full pathname of your wordart application
2) A copy of your \windows\reg.dat file so I can look into that
 
Regards
0
c827451Commented:
Do you have a wordart2.reg file somewhere ?
(c:\windows\msapps\wordart probably)
If you do, could you please open it whith Notepad and search for

HKEY_CLASSES_ROOT\MSWordArt.2\protocol\StdFileEditing\server =
and for
HKEY_CLASSES_ROOT\CLSID\{000212F0-0000-0000-C000-000000000046}\LocalServer =
Please let me know what the values of these two keys are.

0
imran050997Author Commented:
For: c827451

Full pathname of my wordart application is:

c:\windows\msapps\wordart\wordart2.exe

I would need your e-mail address to send you the reg.dat file

values for wordart2.reg file as follows:-

HKEY_CLASSES_ROOT\MSWordArt.2\protocol\StdFileEditing\server = C:\WIN311\MSAPPS\WORDART\WordArt2.exe
                 HKEY_CLASSES_ROOT\CLSID\{000212F0-0000-0000-C000-000000000046}\LocalServer = {000212F0-0000-0000-C000-000000000046}

Thanks!

Imran
0
imran050997Author Commented:
Correction

HKEY_CLASSES_ROOT\CLSID\{000212F0-0000-0000-C000-000000000046}\LocalServer = C:\WIN311\MSAPPS\WORDART\WordArt2.exe

0
c827451Commented:
Change the c:\win311 into c:\windows in both the keys.
You can do this in different ways but the easyest way is as follows:

1) Edit the wordart2.reg file and change the 2 keys
2) run regedit and choose the option <Merge Registration File> from the file menu
After that, your Wordart should run. No need to restart windows.

I do not need your reg.dat anymore, but you can always contact me
at Ruud.VanLooy@ehv.cp.philips.com
(I can only read my mail during office hours, don't have mail at home :-(
Success!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
imran050997Author Commented:
Unfortunately those "fixes" didn't make a difference. I changed the c:\win311 to c:\windows for both keys and ran regedit to merge the wordart2.reg file and the problem still exists.

Can you suggest any reason why the above fixing failed?

Will send you my reg.dat file as well so you can work on that.
0
c827451Commented:
Ok,
I will wait for the reg file (it will be Tuesday before I can look into it. (We have a day off on monday))
I will think it over today and get back to you this evening.
I still believe something 's wrong with the reg.dat file
0
c827451Commented:
Can you find the following DLL's :
ole2prox.dll ctl3dv2.dll and pubole.dll
Renaming them on my PC gives the same error.

Here's a list of files used by wordart2
USER.EXE SDM.DLL STORAGE.DLL OLE2.DLL WORDART2.EXE CTL3DV2.DLL
PUBOLE.DLL OLE2PROX.DLL

0
imran050997Author Commented:
I have a strong feeling it's the PUBOLE.DLL file but can't be sure. Thanks for the tip, I'll see if I can locate those files while I wait on your response.


0
c827451Commented:
Hi Imran,
I looked into your reg.dat and it seems ok. I can even use it on my pc to include wordart2 in MsWord.
The problem probably lies in one of these 3 DLL's :
ole2prox pubole or ctl3dv2.
Would you try and include a wordart2 object in write.exe?
If this works out ok, i suspect ole2prox.dll
If this doesn't work, ole2prox.dll is not the blame (not used by write.exe)
I believe one of these DLL's is either corrupt or missing. If you  can find all three, try and replace them from the installation media. If all that will not give a solution, I can offer you a last resort. I have a utility that can trace all kinds of DOS calls. If the reason of your problem is a missing file, this utility will show it, it the reason is a corrupt file, it won't.
If you can find all three dll's, pls let me know.
regards
0
imran050997Author Commented:
I believe you're quite right. It's one of those .DLL files.

I installed a 2nd Windows directory and re-installed Ms-Publisher via this "new" windows and Wordart worked! However, when I copied all the new DLLs over into my present Windows dir., Wordart worked again BUT then Ms-Word & Ms-Excel presented me with "Undefined Call To Dynalink" so I'm really puzzled! Obviously I will need to re-install all the MS apps again to run everything properly?

Thanks! Imran
0
c827451Commented:
You could do that, yes, but maybe it might be sufficient to just install one of those apps (Word or Excel) Be sure to make a backup of all those mentioned DLL's first.
After the installation, try out Word and Excel for wordart. If all works fine, compare the backupped and newly installed dll's. It's always good policy to use the latest version. (If you have the msinfo.exe, you can use it to determine the excact version and lenght of the DLL's.
I don't know what you installed in that new windows directory, but bare in mind that when you delete that directory, your refferences in your reg.dat could be wrong again.
Success,
Ruud
0
imran050997Author Commented:
Thanks again! I'll look into what you suggested and let you know if it worked out.

Regards
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.