Solved

LILO

Posted on 1997-05-09
7
397 Views
Last Modified: 2013-12-15
I just installed Slackware Linux 3.2.0 w/ kernel 2.0.29 and I wanted to install LILO so I could boot from my hard drive.  I ran liloconfig and told it all the things it needed to know (where to install, etc.) .  I told it to install to the superblock of my root linux partition /dev/hda2.  I want to install it to the superblock because i'm dual booting with Windows NT 4.0 and I use NT's boot loader ntdlr to boot.  I added a choice in ntdlr's boot menu called Linux.  ntdlr is installed in my MBR.  So once I select Linux from the menu, in theory LILO would take over if it were installed.  However, when I try to install it, it gives me an error message saying that there is a syntax error on the 8th line of my /etc/lilo.conf file.  I take a look at it and I can't seem to find what's wrong with it; everything looks fine.  In fact if i'm looking at the right line, the 8th line is just a parameter for the timeout delay so that doesn't make any sense what's wrong with it.    
How do I get around this and install LILO and do I have my configuration setup properly to do this?

My hard drive looks like:

/dev/hda1   NTFS/HPFS 1200 MB
/dev/hda2   Linux native ex2fs 95 MB

here's what my /etc/lilo.conf looks like:

# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
  append = "mount root=/dev/hda2"
  boot =
# compact        # faster, but won't work on all systems
  delay = 300
  vga = normal         # force sane state
# ramdisk = 0     # paranoia setting
# End LILO global section
# LILO bootable partition config begins
  image = /vmlinuz
      root = /dev/hda2
      label = Linux
  read-only        # Non-UMSDOS filesystems should be mounted read-only for checking
# Linux bootable partition config ends

Any help would be great.

Thanks!
0
Comment
Question by:misterb
  • 3
  • 3
7 Comments
 
LVL 2

Expert Comment

by:mlev
ID: 1627466
Why don't you let us look at your /etc/lilo.conf?
0
 
LVL 1

Expert Comment

by:bencur
ID: 1627467
Your lilo.conf would be helpfull.

I just want to say, that you'll have problems.
As I remember, if you want to boot Linux with NTloader,
you have to give it a Linux boot sector.
This you can probably find somewhere in /boot.
It's called boot.something, I don't remember now (length = 512B)

I would prefer booting first LILO, and then boot NTldr.exe.
0
 

Author Comment

by:misterb
ID: 1627468
Edited text of question
0
Master Your Team's Linux and Cloud Stack

Come see why top tech companies like Mailchimp and Media Temple use Linux Academy to build their employee training programs.

 
LVL 2

Accepted Solution

by:
mlev earned 100 total points
ID: 1627469
The parameter to 'boot =' on line 6 is missing,
causing a syntax error.
If you want to use the partition's superblock,
it should read 'boot = /dev/hda2'.
If you want to use the MBR, it should either be erased,
or read 'boot = /dev/hda2'.
0
 

Author Comment

by:misterb
ID: 1627470
well thanks, i'll change that the parameter for boot= immediately to /dev/hda2.  thanks for all the help.

I only have one more problem.  I'm only familiar with the pico editor.  I only have elvis installed on my machine.  I haven't had any time yet to install any more packages besides the base a system.  How do I use elvis, i.e. what are the commands for saving the file and exiting elvis itself.  Then I can edit that file and hopefully it will work.

Thanks again!
0
 
LVL 2

Expert Comment

by:mlev
ID: 1627471
Sorry, never heard of elvis.
Here is a key sequence for vi, if this helps
vi /etc/lilo.conf
6GA/dev/hda2<ESC>ZZ
0
 

Author Comment

by:misterb
ID: 1627472
alright i'll try that
0

Featured Post

Back Up Your Microsoft Windows Server®

Back up all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

rdate is a Linux command and the network time protocol for immediate date and time setup from another machine. The clocks are synchronized by entering rdate with the -s switch (command without switch just checks the time but does not set anything). …
I am a long time windows user and for me it is normal to have spaces in directory and file names. Changing to Linux I found myself frustrated when I moved my windows data over to my new Linux computer. The problem occurs when at the command line.…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

778 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question