Routing Problem with dynamic IP

Hi guys,

i setted up my system with Ip-Masquerading and a ISDN dialup to my host.
the only problem is that when the route is added via:
"route add default ippp0"
in my script i have to do it after i made the connection to my server once again, because i only have a dynamic IP address from my ISP so i have to use 0.0.0.0 in my script.
But this way i can´t get the dial on demand on work without first establishing the connection through the Linux Box.

I really hope one of you guys can help me!

Cya,

            Chris
black_Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bcookCommented:
Add the switch "defaultroute" to the ppp command line or
/etc/ppp/options.

This will set the default route automatically once the connection is made.  This is how I do my setup with dynamic IP addresses and PPP. (This is going through a Linux Masq router with that setup)


0
black_Author Commented:
That is what i´ve already done, but is everytime deleted then after the box has connected!!
What should i do now??
0
bcookCommented:
Do you have a default route already set - what does
route say.

Your message says that you set the default route in your
script. This should not be the case, maybe you could explain the
steps you go through when connecting.

0
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

Hal9kCommented:
You should use the "defaultroute" option at the commandline of ipppd. This tells ipppd to add the default route itself.
However you have to make sure that there is not already a
default route set !

You may also want to ensure that the network part of your local IP-address of your ehternet card is different fron the network address used by your dial-up server.
(i.e. if your server assings addresses to you from the range:
123.45.67.xxx (xxx is a number between 1 and 253) then you
must not use the first 3 bytes (123.45.67.) for your local
ethernet card. Otherwise routing might get confused.
0
black_Author Commented:
I really know that the defaultroute is set by itself, but the problem is that it is deleted after i received my dynamic Ip. Thats what confuses me!
Doesn´t have anyone the sam problem as i, or some scripts that may work for me???
0
xtermCommented:
Add these lines to your script (admittedly it's a little bit
of a hack, but it works):

sleep 5
IP=ifconfig ippp0 | grep inet | awk '{print $2}'| tr -d "addr:"
route add default gw $IP

You may have to adjust it a little depending on how your ifconfig
formats it's output, but you get the idea.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.