We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now

x

Windows 95 Power Questions

jrl187
jrl187 asked
on
Medium Priority
184 Views
Last Modified: 2013-12-16
I'm trying to get a handle on how win95 ( OSR2 ) handles
power saving features. What confuses me is that some power
settings need to be changed in the bios and some in win95.
In the bios I set APM to yes since win95 appears to support
this standard. I set times for Suspend, Doze, and Standby.
My moniter and graphics card support DPMS so I set that to yes. I set a time for the HDD to spin down. Under win95 I
checked the box for windows to handle power. I set the HDD
spin down time here also.

That's the backround. After the proper time the moniter shuts down and the HDDs spin down but the motherboard and CPU don't seem to go to sleep. Since some of the settings conflict with each other, who has control? The bios or win95? How can I get the MB and CPU to sleep, and what is a foolproof way of checking to make sure that they did in fact go to sleep? Sorry for the long question.
Comment
Watch Question

Commented:
This may sound silly, but if your CPU/Mother Board goes to sleep, how is your pc supposed to function? Your disk drive can spin down and monitor can drop power to a minimum level, similar to your TV at home but that's about it.

Just a word of caution here, WIN95's power management may not work properly with all PCs out there, it may cause you more problem than it's worth. If you pc is a desktop, use screen saver for your monitor instead of power saving, if you must leave it for an extended period of time, you can always switch your monitor off and leave your pc running.

Author

Commented:
But when I forcefully put to computer to sleep via the suspend command on the start menu, apparently the CPU does do something since it takes a while for it to get going again. My understanding is that when the CPU is in power saving mode it operates at a much lower speed than normal. The problem is that I can't seem to get windows to do the same thing by itself as manually clicking on the suspend button.
do

Commented:
Some computers, particularly laptops, have a bios oriented or proprietory driver system of transferring all data in RAM to disk and then going into total suspend (Win 95 will not do this).This is meant for maximum battery saving. I would not consider this is necessary for a desktop as the power consumption once the monitor and hard disk have been suspended is negligible.Windows will handle suspense of monitor and hardisk quite adequately. However if you wish to activate suspense manually from the Start Menu you will have to set APM in bios otherwise the Suspend button will not appear.

Author

Commented:
As I said, I have APM enabled in bios and do have the suspend button on the start menu. The problem is that manually clicking on the suspend button puts the system into power saving mode, but on its own win95 never puts itself into power saving mode.

Author

Commented:
Adjusted points to 230
do

Commented:
I am not sure who is not understanding who.What I am trying to say is that Windows 95 on its own will not do what you want. It will only power down the hard disk (power applet in control panel) and power down the monitor (screen saver tab in display properties (if your monitor supports DPMS))which you say they do). Windows 95 will NOT transfer data in memory to disk and shut down the entire system to standby. You need proprietory dos drivers and/or bios settings to achieve that.
Commented:
You can only accomplish what you are trying to do with proprietary drivers, or a notebook, as most new notebooks have this feature, as to save battery life... Sorry.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
I found the problem. I had windows polling the CD-Rom for auto insert stuff, and so the Bios thought this was disk access. Once I turned off auto play everything worked fine. Thanks though.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.