Solved

Dial-Up vs. Trumpet: very low transfer speed

Posted on 1997-05-13
10
178 Views
Last Modified: 2013-12-16
I used to have a 486 with Win 3.11 and a 14400 USR modem. To connect with the outside world I used Trumpet Winsock software which I got from my University. It worked fine. Then I made a massive upgrade to a Pentium and installed Win95+. I kept the old dial-up software (Trumpet) but also
installed a new package called Inet 2.0 (again provided by the University) which worked using Win95 Dialup. Although I was told that Trumpet was not supposed to work under Win95 it still worked great. However, when I started using Inet with Dial-Up I found that although dialup says that it connects at 12000, it works painfully slowly when I use Netscape or when I download files to my comp using FTP. Transfer speeds are around 500 Bps. I played with the baud rate setting, network parameters and other stuff and reinstalled both Dial-Up and Inet but nothing seems to help. BTW, both "software compression" and "IP header compression" were checked but that did not change anything.
0
Comment
Question by:ilyaz
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
10 Comments
 

Expert Comment

by:vladimir_
ID: 1746788
Try to enable the "software compression" in server type,
turn on "Use IP Header compression" in Server type/TCP/IP settings.
0
 

Author Comment

by:ilyaz
ID: 1746789
Both "software compression" in server type and "Use IP Header compression" in Server type/TCP/IP settings were checked before. Are there any other things I could do?
0
 

Author Comment

by:ilyaz
ID: 1746790
Edited text of question
0
Online Training Solution

Drastically shorten your training time with WalkMe's advanced online training solution that Guides your trainees to action. Forget about retraining and skyrocket knowledge retention rates.

 

Expert Comment

by:infoghost
ID: 1746791
Get rid of trumpet alltogether. Win95 works at it's best with it's own Dial-up Networking. Make sure you have the "microsoft protocol tcp/ip" selected.
0
 

Author Comment

by:ilyaz
ID: 1746792
I need clarification from infoghost. What if I don't use Trumpet without deliting it from my computer? Should this affect performance of Dial-Up? What I don't understand is how Trumpet can cause any changes if I, say, use Trumpet today and Dial-Up tomorrow. Do they both access the same special files of some sort so that if Trumpet is EVER used the files are changed and Dial-Up experiences problems? Thanks.
0
 

Expert Comment

by:vladimir_
ID: 1746793
Maybe i wrong, but what, if Inet use private settings. Try to use
clean Dial-Up networking
0
 
LVL 1

Expert Comment

by:nylja
ID: 1746794
I havent so far (Ive set up >200 Dialups) seen or had any need to use anything but win95's built in dialup. Its easy to use, its fast, its supported by a BIG company and its free.

0
 

Author Comment

by:ilyaz
ID: 1746795
Reply to nylja:

Do you mean Dial Up with nothing else like Inet or or Dial Up with whatever the necessary additional software there is? If it is the former then cen you tell me if there are built in Telnet and FTP capabilities in Dial Up. If it is the latter then I just want to clarify that the reason that I keep using Trumpet is not because I have any sentimental feelings about old software but because Dial Up is not functioning properly.

Thanks for your comment, though.


0
 
LVL 1

Accepted Solution

by:
jinx051597 earned 70 total points
ID: 1746796
1. Disable compression on your modem
2. Under the 386Enh section put:
COMxBuffer=1024
(where x is the Comport #); you can disable error correction by un-checking that box under the modem settings and adding the string:
AT%C0 to the extra settings area in the modem settings.
To improve your ports speed, go to “ Control Panel | System | Communication Ports , then double-click the port your modems in, then click the Properties tab and set the Port Speed to 921600 BPS;

Try these
registry:
\ HKEY_LOCALMACHINE \ System \ CurrentControlSet \ Services \ VxD \ MSTCP \ DefaultRcvWindow -> 64000 instead of 4*(MTU+4)
\ HKEY_LOCALMACHINE \ System \ CurrentControlSet \ Services \ VxD \ NWLink \ Ndi \ params \ maxsockets \max -> 1020 instead of 255
Use IP header compression with it if you use a PPP-server.

If all this fails your new modem might not be as good as you old one. Also try changing the modem type from your modem specific to a standard win95 type driver in the modem control panel.
0
 

Author Comment

by:ilyaz
ID: 1746797
Thanks!

After I changed Port Speed it started transfering with speed of about 1.34 KBps which is, I guess, good enough for a 14400 modem.  Anyway, I want to ask you what 386Enh in Win 95 is.

Thanks again
0

Featured Post

SharePoint Admin?

Enable Your Employees To Focus On The Core With Intuitive Onscreen Guidance That is With You At The Moment of Need.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article, I will show you HOW TO: Install VMware Tools for Windows on a VMware Windows virtual machine on a VMware vSphere Hypervisor 6.5 (ESXi 6.5) Host Server, using the VMware Host Client. The virtual machine has Windows Server 2016 instal…
Determining the an SCCM package name from the Package ID
In this video, we discuss why the need for additional vertical screen space has become more important in recent years, namely, due to the transition in the marketplace of 4x3 computer screens to 16x9 and 16x10 screens (so-called widescreen format). …
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

737 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question