WHY PPPD REFUSES TO GIVE TO WIN 95 DNS NUMBERS ???

I'm an ISP Admin in trouble with pppd, can you give 3 minutes of
attention to me ?
My problem is that I'm not able to give to the WIN95 machines of
my modem-clients the IP address of the dns, and so they claim that
it's impossible to navigate (of course :-). I' ve tried to exchange
the order of the options i pass to pppd in the login.config file
of mgetty, but it doesn't work. So there is the row of the file.
Please tell me what's wrong ....

 /AutoPPP/ - @ /usr/sbin/pppd 115200 -detach -pap -chap login proxyarp \
netmask 255.255.255.192 modem crtscts dns-addr 194.244.100.164

Then in /etc/ppp/options.ttyS?? i have ...

194.244.100.167:194.244.100.168

that's the unique parameter that is modem-specific

I use ppp-2.2.0f and mgetty-0.99.3 ....

Many thanks in advance

Giovanni C.
joker0Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dhmCommented:
This is an easy one...pppd must be compiled with the C preprocessor option USE_MS_DNS defined.  (I.e. when you compile, you must add "-DUSE_MS_DNS" to the compilation options.)  The binary version supplied with RedHat-4.0 and 4.1 (I think) was not compiled with that option, so the functionality is not present.

You can check to see whether the functionality is present with this command:

$ strings /usr/sbin/pppd | grep dns

If you see "dns-addr" appear, you've got it (and this answer is wrong); otherwise, you'll have to recompile your copy of pppd.  (But don't forget to accept this answer! :-)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
joker0Author Commented:
We have had the same idea probably with a gap of 3 hours :-))))
But anyway your question is good and acceptable. Many Thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.