?
Solved

Iomega ZIP 100 and NT 3.51

Posted on 1997-05-14
11
Medium Priority
?
323 Views
Last Modified: 2013-12-14
I recently added an Iomega ZIP 100 to a networked NT 3.51 SP4 machine.  During the installation, the ZIP took over drive D: and apparently pushed all the other connections back a drive letter.  The next time I booted, I received many errors, the majority were fixed by changing the path for icons in program manager to the new path.  But, I have two errors that won't go away.  One gives me the message: ntvdm.exe - No Disk  There is no disk in the drive. Please insert a disk into drive E:.  The other says: Program Manager - domain\user: progman.exe with the same message about the E:.  Drive E: was previously a networked path on the server.  The user can push ignore when prompted and all operates as normal.  Also, it appears that the ZIP created a new hidden file called progman.gid which I have no idea what it is for, as none of my other computers contain it.  How can I make these errors go away?
0
Comment
Question by:RBourgeois
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
  • 2
11 Comments
 

Expert Comment

by:kangadru
ID: 1765164
You failed to say if this was a SCSI or Parallel ZIP-100, but from your problem I would assume it is SCSI.  The problems that remain are REgistry related and ugly to fix in the current environment however, if you simply unplug the SCSI Zip-100 from the loop for a boot and then readjust your drive letters according to the old locations and then reconnect the Zip device for your next reboot it should place the Zip Device at the end of the chain and you will have to adjust those shortcuts again but the other problems should go awayJaz installs do a similar problem.Andy
0
 

Expert Comment

by:kangadru
ID: 1765165
Eeps!  I missed one other item, Your configuration of the netdrive on E: could also be the problem and using Disk Administrator you should be able to push the Zip Drive letter out to Z: or something similar to prevent the errors as well.Andy
0
 

Author Comment

by:RBourgeois
ID: 1765166
Actually, it's am parallel ZIP.  I received a similar answer from someone on a newsgroup just this morning.  When I unplugged the ZIP, it gave me a Blue-Screen-Of-Death.  So, I tried to use press spacebar to use last known good config, locked the system.  Barring all else, I plugged the ZIP in, logged into admin and entered disk administrator.  Changed my CD-ROM from e: to y: (z: is used by the network for users account space) and the errors went away.  Unfortunately, it's only a temp fix as when I put it back to e:, the messages returned.  Also, it won't let me change the drive of the ZIP, otherwise that would be the route of choice.  Is there something I can do to fix the CD back to e: and lose the messages in the registry?  Thanks for the insights above.
0
Supports up to 4K resolution!

The VS192 2-Port 4K DisplayPort Splitter is perfect for anyone who needs to send one source of DisplayPort high definition video to two or four DisplayPort displays. The VS192 can split and also expand DisplayPort audio/video signal on two or four DisplayPort monitors.

 
LVL 5

Accepted Solution

by:
cer earned 240 total points
ID: 1765167
I had the same problem with a MO-Disk (SCSI) on NT4.0
The problem is that NT does NOT allow to assign a drive letter to a removable media, therefore ZIP allway comes to d:
There are two solutions:
1. Reinstall the whole system. Assign driveletters leaving space for D: (the ZIP which installes later). This method is not good because all software has to be reinstalled.
2. Use UNMNT10.ZIP from the internet to reconfigure your Driveletter. This must be done in a batchfile which executes at startup (for which you must install AUTOEXNT from the resourcekit)

0
 
LVL 5

Expert Comment

by:cer
ID: 1765168
Short selfmade UNMNT description for that purpose:

Use

      MNT

to see a list

example:
~~~~~~~~~
A: => \Device\Floppy0
C: => \Device\Harddisk0\Partition1
D: => \Device\Harddisk0\Partition2
E: => \Device\Harddisk2\Partition1
F: => \Device\LanmanRedirector\F:\ntsvww4\public
G: => \Device\LanmanRedirector\G:\NTSVWW4\Progs
H: => \Device\Harddisk1\Partition1
I: => \Device\CdRom0

E: is MO and should be moved. Therefore unmount E:

      mnt -u E:

Mount as J: (Since the name don't change I hardcoded it)

      mnt J: \Device\Harddisk2\Partition1

E: is now unused and will be used as network drive later.
C,D and I are fixed using HD-Manager

Share it:

        net share MO-Laufwerk=j:\ /users:1 /remark:"Server - Userraum" /yes


===================================================

What was your previous D: ?
Be sure to move the drive letter at the very beginning in the autoexnt, autostart group does not work because network is already mounted.
Be sure to use absolute pathnames in autoexnt when calling a programm, no environment is set, no network. The user executing autoexnt is SYSTEM

0
 

Author Comment

by:RBourgeois
ID: 1765169
It may work, I have to get the unmnt and try it.  But, as stated above, I found an answer that will but temporarily fix it.  All works fine, except that I can not put anything on E: at the moment.  Thanks...
0
 
LVL 5

Expert Comment

by:cer
ID: 1765170
My solution may seem too complicated to you, but you will see it is the only useable one with removable media.
You did say it is a temp fix, and you did ask for a solution to move the ZIP drive letter ("Also, it won't let me change the drive of the ZIP, otherwise that would be the route of choice").
I worked a lot on it for our own system and found no other solution. You will find it much more valuable than the bad grade you gave me.

0
 

Author Comment

by:RBourgeois
ID: 1765171
I didn't mean that as a bad grade, I'm sorry that you took it that way.  And, I do appreciate the info...this is the first time I've used this service (I have one other question on it at the moment), so bear with me as I learn what's considered a good grade for the info received.  Also, I hadn't had the chance to try it yet, so I'm not sure if it works...I opened up the comments and it asked me to grade the response, so I did with the knowledge that I had.  But, for one thing, I would have appreciated a site to find UNMNT10.ZIP.  After I find it and give it a try, is there a way to change the grade?
0
 

Author Comment

by:RBourgeois
ID: 1765172
cer -- I downloaded a copy of UNMNT10.ZIP and tried your solution.  What I received from the mnt listing was:

A:=>\Device\Floppy0
C:=>\Device\Harddisk0\Partition1
D:=>\Device\Harddisk1\Partition1
Y:=>\Device\CDROM0

There was no mention of E: or any indication as to why I get the previously reported E: error stating no disk loaded.  If I go to disk admin and change my CDROM to E: the errors return.  Put it in as Y: and they disappear.

I do see what you were saying about removing it, redirecting it, and all's OK...but I see no reason for the error since mnt reports nothing connected to E:.  Does that mean I should use the mnt on D: (which is currently the IOmega) moving it to E: and redirect the CDROM to D:?

btw - D: used to be the CDROM in answer to your question.  E: was originally a network share connection which has hence been moved thanks to the IOmega taking over the drive locations.

Also, I have no file called autoexnt.  I do have a blank autoexec.bat in the root on C: and a autoexec.NT in my system32 directory, but it has no drive locations listed in it.
0
 
LVL 5

Expert Comment

by:cer
ID: 1765173
I got 125 Points for the answer. This is a multiplication factor of "1" which is the lowest grade you can give (besides "fail"). You may want to read the
"Expert gradin help" (http://www.experts-exchange.com/info/grading.htm)

If you did not try it yet you should have start the discussion about the answer _without_ grading (Just do not mark any grade)! You can grade later.

Changing a grade is not possible. This (grade to early) happens often to me and therefor I mailed the support staff. Hope it helps.

Finding such a programm is not too difficult. Try http://www.shareware.com

Maybe because you do NOT have E: you do not have an error. i do not know where the error comes from, but may this source do not see an E: and therefore keeps quite.
I am starting at the state where your system was working without the ZIP. You need to keep the drive distribution (fixed, cd-rom and shares) and should only install the ZIP to a free drive letter. This installing is only possible with the MNT Utility.
I do not know if and how you messed up your system by trying something else. You say you get a "no disk in drive" error. Some programm (which hides in the registry) want to use something on E:, if there is none it is failing. If there is a CD-ROM it is not writeable and you get a error.
You can only move the driveletter at NT-startup. Therefore you need

AutoexNT. This can be found in the NT server or workstation resourcekit. This kit is a documentation and a CD-Rom where you can find much information. I use it often. You have to buy it.
Nevertheless I found it on the web:   http://www.searchlight.com/$webfile.files.spinnakr.@.25
I didn't compare it to see if it is really the same, but have a try.


0
 

Author Comment

by:RBourgeois
ID: 1765174
Thanks, I'll check it out.
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Sometimes clients can lose connectivity with the Lotus Notes Domino Server, but there's not always an obvious answer as to why it happens.   Read this article to follow one of the first experiences I had with Lotus Notes on a client's machine, my…
Know the reasons and solutions to move/import EDB to New Exchange Server. Also, find out how to recover an Exchange .edb file and to restore the file back.
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question