Solved

Applications quitting due to type 10 errors

Posted on 1997-05-18
9
310 Views
Last Modified: 2012-05-04
I have a Performa 6115 CD PPC.  24 of RAM.  System 7.6.1.  Open Transport 1.1.2.
This problem developed after upgrading to system 7.6 & 7.6.1.
I have no trouble connecting to my local provider.  When I try to "check mail" in my e-mail program, (Eudora Lite 3.1), I get the message:

        "The application unknown has unexpectedly quit because an error of type 10 occurred."
   
When this occurs none of my Internet related software, (Eudora, Newswatcher, Netscape 3.0) will function until the computer has been restarted. About half the time it will freeze on restart, (I think after the extensions have loaded).  It doesn't occur every time. It rarely will occur just when opening the application even before I have started my Free PPP. Sometimes it will occur in Netscape when I'm trying to open another URL. Sometimes it will happen at the end of a session when I am actually quitting the application. (This actually started after upgrading Open Transport to 1.1.2).

It occurs with:
    Speed Doubler 2.0.3  on or off
    Conflict Catcher 4.0 on or off
    Virtual Memory on or off

I have trashed the Finder preference and the TCP/IP preferences. No change.
I have run Nortons Disk Doctor and Speed disk, rebuilt the desktop and zapped the PRAM.  Eventually it will occur again.  It does not occur in any other application.

While I was trying to register with your service, I tried to save the Guidelines and I received this message:
        "There is not enough memory to keep the window hard disk open".
       When I clicked on OK I received this message:
    The application Netscape Navigator 3.0 has unexpectedly quit because an error of type 20 occurred.  This has never happened before.
0
Comment
Question by:dmggmd
9 Comments
 
LVL 4

Expert Comment

by:rifty
ID: 1536112
Type 10 is an unimplemented trap. (Huh?) Not much help as it means that the system can't find an instruction. Have you tried moving the Eudora and Netscape Preferences to the desktop and rebooting? Have you got some old extensions operating that are causing a crash with the upgraded system? To check this, disable all but the essential extensions and control panels by moving them out of the usual folders and reboot.

Try that if you haven't already. If it works, then please allow me to submit this as an answer; I don't think I've done enough to submit this as anything but a comment.

Rifty.
0
 
LVL 1

Expert Comment

by:gustav041897
ID: 1536113
Have you re-installed Eudora? You didnt say
0
 

Expert Comment

by:millertk050797
ID: 1536114
I was interested in your problem because I have been having the same problem on a PB 1400 and MS Word mostly.  The only item we seem to have in common is the use of Open Transport.  I'll try it in the morning to see if that clears things up.

Tom
0
 

Expert Comment

by:Xenotech
ID: 1536115
Error 10 could be caused by two things: either there's a bug or corruption of your Eudora application (and reinstalling it could fix the problem) or...

Sometimes, when MacOS can't figure out why something went wrong on a PPC system, it just spits up a Type 10 error.

Because it only occurs when you run Eudora, I would try downloading a newer version of Eudora Lite (or buying a commercial version of Eudora).  Make sure you trash Eudora's older preferences file.

Your second problem, with Error Type 20, might be related to your recent upgrade to System 7.6.1.  Errors in this range are generally related to a corrupted system file.  If you have sufficient hard drive space, you might want to try a 'clean reinstall' of your system.  This is accomplished by holding down the command (apple) + Shift + K when you're in the Installer dialog window.  Check the "Install New System Folder" radio button and click "OK."

This kind of install creates a new System Folder and a folder called "old System Folder" which contains all your preferences, extensions, fonts and other stuff from your previous system.

If the system file is corrupted, it could be causing the errors with Eudora and Netscape when they make calls to certain system instructions.

Finally, if neither the system file or applications are corrupted, the problem could be related to bad or damaged RAM.

Good luck.

0
Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

 
LVL 1

Expert Comment

by:dooly
ID: 1536116
If all else fails, try OT/PPP instead of FreePPP.
0
 

Accepted Solution

by:
okp earned 200 total points
ID: 1536117
What you are experiencing is probably a DebugStr call. Try installing MacsBug and repeat the operation. You should see something like "User Break at <name>+offset" in an awfull text screen (you will feel better if you set your screen to 256 colors), then type "g" and return. You might be able to continue working... or might not, depending on what the message tells. Anyway, you will see the name of the probably guylty application (but it might be a driver or anything that crashed at interrupt or completion, in which case, the active process is not necessary the one that initiated the crash leading operation...)

anyway, it will prevent you from getting a meaningless message.

Just in case, you can type "es" and return if the app loops in the message you get.
0
 

Expert Comment

by:onpatrol
ID: 1536118
Type 10 error code!
Have you got a hidden 'RAMDoubler" file on your disk?
Restart with extension off. Adjust your memory control panel as follows: Reduce your cache to run @ 256 - turn your RAM off - turn your Virtual Mem. off.
Restart & rebuilt desktop
0
 

Author Comment

by:dmggmd
ID: 1536119
Sorry, I took so long in responding, life has been pretty hectic.  After trying everything I could think of, (and before I got a chance to read the help suggestions), I re-installed the older versions of Eudora Lite (back to 1.54), and Netscape, (2.01), that I had been using and ALL problems went away. I have had no problems of any kind since. Of course, now I'm trapped unable to upgrade, but at least everything is working as it was intended. Thanks so much for the help.
0
 

Expert Comment

by:huzer
ID: 1536120
Technically, an Error 10 is caused by a missing or corrupted system entry point.  In practice this usually means one of three things: (1) the application in question has become corrupted, (2) the application has failed to check the current MacOS and/or ROM version, or (3) the entry point to a specific routine in the MacOS has become corrupted.

This being the case, you can usually solve the problem by first upgrading/re-installing the application(s) in question.  If this fails to solve the problem, there's a good chance your System file has become corrupted.  You can either try to retrieve a copy from a fairly recent backup, or if that's not possible, perform a "clean" MacOS re-install.

If you have an alternative disk or partition available, you might consider installing the appropriate MacOS version on that disk as a temporary measure.  Once that install is complete, boot from this new system and simply copy the new System file over to the old System Folder, replacing the old file.

The downside of re-installing the System or the System file is that some software installers will insert custom resources into the System file as part of the installation.  Since you're replacing the old System file, all of these custom resources will be lost.
In my experience, however, this is seldom a serious problem.  Your mileage, or course, will vary.  If after replacing the System file you experience problems with certain apps, simply re-install them.

0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Change ip +gateway in mac is 10.8 7 59
how to install MAC OSX on a MAC that has windows installed 5 49
I have bought an old Apple Mac 7 65
Reinstall Mac OSx 13 44
Apple's Mac OS X has become an official member of the malware club. The Flashback Trojan has affected over half million Macs, worldwide. It is behavior that ultimately gets malware onto a person’s computer. Obsolete or out-of-date software helps…
In this article we will discuss some EI Capitan Mail app issues and provide some manual process to resolve them.
This Micro Tutorial will give you a basic overview how to record your screen with Microsoft Expression Encoder. This program is still free and open for the public to download. This will be demonstrated using Microsoft Expression Encoder 4.
With the power of JIRA, there's an unlimited number of ways you can customize it, use it and benefit from it. With that in mind, there's bound to be things that I wasn't able to cover in this course. With this summary we'll look at some places to go…

920 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now