Solved

Internet service/connection stops responding

Posted on 1997-05-23
53
530 Views
Last Modified: 2008-03-06

During an internet session the internet or my ervice stops responding.  Everything--e-mail, news server, browser/web--all (and each alone) stop responding.  The modem is still solidly connected and reports a good quality phone line.  The service detects that I'm there because it will leave me connected after this starts until their inactivity timer disconnects me (e.g, 20 minutes later).  

When it happens applications (e.g., mail reader, news reader) report various winsock errors.  A frequent one is # 11004 which they variously describe as "NO DATA OF REQUESTED TYPE.  Couldn't resolve host name or address."  and "Host name not found."  Other error codes returned are 11057 & 11060.

I see different modem activity patterns:

o  The most common--there's data transmission but no receive.

I have tried 3 different services and all do this, but with varying frequencies.  My main service does it on about 1/3 of all connections, another does in about one time in 10.

I have no other W95 anomalies.

Here's some new information:

o   I have exchanged the modem for another of the same model number.  It didn't have any effect.

o   I have learned if I force the modem to connect at lower speeds the problem seems to go away.  It didn't fail for several days at 19200 bps.  I've been running for about a day at 24000 bps without an event.

o   When the event occurs, my end continues to send (modem transmits), but the IP end doesn't respond.  If while my end is still trying I disconnect and reconnect things usually begin working again.  (My end will eventually quit trying.  Read on.)

If while the problem is happening I run the PING program it will attempt to send (my modem transmits) for a minute or 2 then reports "BAD IP Address.." and quits.  If I let it continue to try until I get this message it will not try to send anymore if I rerun PING or any internet program, until I reboot.  After reboot, everything starts working again for a while.  

If I interrupt PING before it completes (reports failure), I can run PING time and again and it will always send.  Also, I can disconnect/reconnect to the IP and PING & internet apps will work again.

system:
Pentium 133
PCI MotherBoard
32 megs memory
Diamond Stealth 3D 2000 video card
3gig+ & 1gig+ EIDE 10ms access drives
Toshiba 4X CDROM drive
Practical Peripherals PM288MT II V.34 modem
SoundBlaster 16 sound card
LAN card
QLogic SCSI card

W95 updates installed:
service pack 1
win32 kernel core component
disk TSD virtual device
SLIP & Scripting support for dial-up networking
OLE update
ISDN update
more
0
Comment
Question by:houston
  • 32
  • 7
  • 4
  • +6
53 Comments
 
LVL 2

Expert Comment

by:kolarb
ID: 1816241
What about the maker of your modem (the most important piece of info)?

If it is USR Sportser purchased prior to something like october 1996 then ask USR about the problem (or add S12=0 to initialization string)
0
 

Author Comment

by:houston
ID: 1816242
modem is Practical  Peripherals PM288MT II V.34 bought circa October '96.
0
 
LVL 2

Expert Comment

by:kolarb
ID: 1816243
Check out the homepage of your modem. Perhaps you will be able to download newer drivers. I really think the modem is to be blamed.
0
 

Author Comment

by:houston
ID: 1816244
I check with them again, but I took my problem to the modem people (they have a CompuServe support forum) months ago, and they denied knowing of any such  problems.   I am using the driver and AT commands they reccommend.

0
 

Author Comment

by:houston
ID: 1816245
Edited text of question
0
 

Author Comment

by:houston
ID: 1816246
Please don't let any discussion of exploring alternatives stop you from trying to solve this problem.  It's driving me nuts.
0
 
LVL 2

Expert Comment

by:kolarb
ID: 1816247
How about getting a modem from a friend and testing if the problem persits?
0
 

Author Comment

by:houston
ID: 1816248
I have in fact tested it with my old 14400 modem.  Same problem.

0
 
LVL 2

Expert Comment

by:kolarb
ID: 1816249
Well how about your phone line. Do you have multiplex, shared line etc. I doubt that this is a hardware problem (two different modems), it may be a software problem but none that I heard of before. I have another test for you - go to another location and test your computer there. It may well be a phone line's fault.
0
 

Author Comment

by:houston
ID: 1816250
Damn, I just typed in a long reply and clicked the wrong button and lost it all.

That seems like a good idea but hard to do.  Remember this is an intermittant problem.  I sometimes go for a day or more without it happeining.  Other times it happens 7+ times in a row.

Also, It wouldn't eliminate the phone line--it would only eliminate the modem.  Using my old modem should have done that.  I think it W95.

I have 2 phone lines and it happens on both.

0
 
LVL 6

Expert Comment

by:jpk041897
ID: 1816251
Next time it locks up on you, try pressing <alt><ctrl><del> and see if any of the programs is reported as "Not Responding".

I have encountered similar problems in the past, although rarely, and have usualy been able to associate them to another (and usualy totaly unrelated) program.
0
 
LVL 1

Expert Comment

by:tavkhelidzem
ID: 1816252
What is your winsoc? is it native Win95 or some other (Trumpet for eg)?
The problem might be there.
0
 
LVL 2

Expert Comment

by:kolarb
ID: 1816253
Addendum: you said that one ISP locks up more often than the other. Is it true or are you just using one service more than the other? If the problem acts differently from one ISP to the other it might be the phone line.
0
 

Author Comment

by:houston
ID: 1816254
to jfk

I'll try to check that.  Normaly it doesn't really "lock", the other end just stops responding.  Usually if I try to check mail or go to a web site the modem transmit lamp flashes--there is just no receive response.
0
 

Author Comment

by:houston
ID: 1816255
to tavkhelidzem

The winsock is native W95.
0
 

Author Comment

by:houston
ID: 1816256
jpk

it happened just now and I lost a reply I had prepared here.  All programs closed normally.  That't the only way I know to test for not responding.   I did not try to end task on the power toys I run.

I have never seen a program hang when this happens.

0
 

Author Comment

by:houston
ID: 1816257
kolarb

I am certain it happens MUCH more on one than the other.  Others people I know who use the provider it happens on frequently do not have this problem.
0
 
LVL 4

Expert Comment

by:rifty
ID: 1816258
Does it happen if you open the connection for email ONLY? I just came into this discussion way down here and it seems to me that one thing you haven't done is to try to isolate whether or not a particular program is locking the connection. I suspect it is your browser, which is why I suggest simply opening your email connection and seeing if it works fine. Alternatively, if it locks up with only that on, try using just your browser without email on. Is this making sense to you?

If it is one of your programs, then we have a chance of sorting it out more quickly.

Rifty

PS I also suggest that if you are losing your responses (as happened twice above) because of this problem, that you write your comment in your word processor, save it, and then paste it into this window.  It would save you some aggro!!
0
 

Author Comment

by:houston
ID: 1816259
rifty

I don't know what all you can read when you come into an ongoing exchange.  In the original problem definition I tried to explain it happens in each and all of my internet  applications--e-mail, news reader, browser, FTP.  

Actually it only blew away one message prep.  You saw 2 references to the same event.  Those comments were written one after another.  

houston
0
 

Author Comment

by:houston
ID: 1816260
additional to rifty

On second reading my first reference to loseing a message was operator error.  I hit the close browser button by mistake.
0
 
LVL 2

Expert Comment

by:helper
ID: 1816261
What's the size of your disk cache file?  I assume, and hope
you are clearing it regularly.  The symptoms you describe
are characteristic of this condition.

Just a thought...  
0
 

Author Comment

by:houston
ID: 1816262
helper

You've gotten beyond my understanding of W95.  It has more caches than Bayer has aspirins.  I don't flush any of them.  

If you mean the \windows\temporary internet  cashes, there are 4 ranging in size from 8 to 12 meg.  I never flush them.  I assume W95 manages them.

If you mean the real disk cache, I've never flushed it in any application I ever used and believe it flushes automatically on power off.

If you  mean the virtual memory cache, I don't flush it either.

If you mean the "recent" folder, I DO flush it on every reboot.

Does all this make sense?

0
 
LVL 4

Expert Comment

by:rifty
ID: 1816263
OK, I'll try again. In reference to your comment on mine above, I think I can read everything that you've said and that other people have said. I understand your frustrations, but just because you understand what you mean by what you write, it doesn't mean that it is clear to everyone else, as we're not actually looking over your shoulder. When I asked you if you tried each of the applications in isolation I was trying to ensure that you had *only that application open* and *none* of the others. It still isn't absolutely clear that you tested it this way, though I assume from what you have written subsequently that you have tried them individually.

If that is the case, then what helper said won't be the cause - though his advice was sound if you were finding the problem happened when using the web browser only. That puts it back on the connection itself, where you seem to be pretty sure the problem lies (you may well be right....)  What modem init string are you using?  

Rifty.

Please note that seemingly irrelevant questions may be asked in order to eliminate some of the more obscure possibilities.
0
 

Author Comment

by:houston
ID: 1816264
rifty

The answer to what's the init string, is complicated.  

The driver PPI supplies with the modem doesn't work.  I know this from more than just my experience.  It didn't work for 2 other friends who also have this modem.  PPI told me to use the W95 Standard 28800 modem driver.  This is also what the other people with the modem use.  This setup essentially just uses the setup the modem loads at power-on.  In my case this is the first EPROM stored profile or register set--profile 0 (&Y0).  

The modem cannot report the status of several of it's critical registers so it is impossible to know what the actual init string is. The profile I use was created from the factory profile tweaked a little using the latest Procomm MODEMS.DAT file.  The DUN  ModemLog does not report any errors, and the connections seem to work fine in DOS com programs.  I have never had any problems on BBSs or other dial up services using DOS Procomm.
0
 
LVL 2

Expert Comment

by:helper
ID: 1816265
Heh...doubt if I can go beyond any of the Win95 knowledge here,
mainly because I wouldn't do 95.  I have virtually none of the
problems that others talk about in these conferences, mainly,
I believe, because I stuck with Win 3.1.  I just know that
a number of people haven't been warned about their browser
cache memory and then they find they have a meg of it on file
and wonder why their system is running [much] slower and eventually crash and can't get back on line for any amount of time before the next crash.  I've seen people give up the web
for just that reason!

So, if you are running Netscape, check the disk cache often,
[regardless of the outcome here, its just a good tip].  Go to
"Options" then "Network Preferences" then "cache".  You will
see a button to "Clear Disk Cache Now" and as it says, that
cache part of it is solved.

If its your connection, then change your ISP, there are litterally thousands to choose from, C/net has a great list
of providers at:  
http://www.cnet.com/Content/Reviews/Compare/ISP/national.html

You can even see how your ISP stacks up against the others.

For the future, if you want to run diagnostics on your modem,
you can get a copy of Modem Dr [Modemd70.zip] at:

http://www.shareware.com


I've also learned, that when freeze-ups happen, to shut down my
computer [regardless of the cause of freeze] wait 10 seconds
and turn it back on.  Mainly because this keeps the memory
from getting all screwed up.  Then when I turned my computer
back on....clear the [browser] disk cache for sure,
run defrag, then scandisk....a bit of work but I've had files
crosslink on me then use "reboot" and have more files get
involved in the crosslinking, till my memory was gone!
Virus?  Naw...just bad technique.

Don't worry about any points for me, I'm just curious how this
will turn out.... :)  These others have obviously been working
their tails off trying to help, and I've seen nothing but good
stuff from them.  Hang in there, it will all come out allright
and you'll have one of the best educations in problem solving
in this area that you could ask for...

Take care....




0
 
LVL 6

Expert Comment

by:jpk041897
ID: 1816266
WHy don't you try to eliminate several aspects at once. This just might help pinpoint the problem.

Download the trumpet winsock from:

http://www/trumpet.com.au

and use it instead of windows for a while.

The trumped winsock has an initialization file that allows you to change the init string for the modem, so you could try tweaking it to a better configuration then the default..

Work with it untill you have a lockup, if it doesn't lock up the problem is with the Win95 winsock and/or your modems driver. If it does, tweak the init string. After a couple of tries, you will have a much better idea of whats going on, or at the very least you will have eliminated a whole range of possible causes.

If it does solve the problem, tell us what it was you did and some one here will be able to tell you how to duplicate that under Win95's Winsock.
0
Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

 

Author Comment

by:houston
ID: 1816267
helper

The problem has happened across 3 providers, 2 phone lines and 2 modems, and it happens when I am only using the mail reader, or only FTP or only Agent news reader.

Incidentally, it has happened twice while I've been composing the last 2 comments and I've had to log off and back on twice to post them.  I now do like rifty said and compose offline.  But it's not really necessary,  I can keep typing into the comment form even after the other end stops responding.  I just can't save/submit the comment until I disconnect and reconnect.

Make that 3 times.  I have a hunch the problem's worse when there's heavy traffic on the provider but I can't know that.

Make that 7 times.
0
 
LVL 6

Expert Comment

by:jpk041897
ID: 1816268
At this stage I would suggest you download trumpets winsock from:

http://www.trumpet.com.au

Its a 16 bit app thunked to 32 bit (so it will probably hit your performance) but it will allow you to discard several possibilities at once and perhaps even pinpoint the solution.

First ty running with Trumpets default settings, if the problem persists, then its not associated with your modems device driver under Win95.

If the problem shows up again, try twajing Trumpets login.cmd file. Change the init string to something better than the default.

If that solves the problem than we can propose a fix under Win 95. If it doesn't than the problem is more likley than not, hardware (or Modem bios) related.

To offset for the decrease in efitiancy during the testing period, take a look at:

http://www.sns-access.com/~netpro/maxmtu.htm#win95

to optimize the MTU setting on your box (should double your throughput.

On second thought. Try running with the MTU fix only. I ran into a modem problem years ago in which (for reasons I never was able to determine) if the modem timed out it would not empty its nbuffers causing a hang. So although a bit farfetched , the MTU idea could posibly fix the problem and it certanly won't hurt.

If that doen't woork then try the trumpet idea.
0
 
LVL 2

Expert Comment

by:helper
ID: 1816269
Hello again houston,

   I also went through a number of ISP's till I found on that
had a good local connect, which is the largest part of the
problem.  I don't like getting cut off numerous times during
acitivity.  But, you know, the truth of the matter, my truth??
heh....is that there are more problematic servers than not.
I went through AOL, Compuserve, Netcom, Powernet, before I
got settled with my present server.  And I don't think it was
necessarily that the companies themselves were bad, not at all.
The problems were from the local access points.  You get weak
ones and you're out. Thats the trick, so if you feel 2 or 3 is too many, well maybe you might want to rethink that. Or put it
on a shelf at least, I know it can be costly jumping from one
server to another, especially and at what point in time you
move.  However, I would encourage you to look over the list
at C/net.  I think there were 65,000 people involved in the
survey, and the results are quite interesting....no doubt.

 Good luck...I'll stay outta this as I've pretty much contributed
all I can, but I'll be lurking to find out what conclusion you
come to.

 Take care...
0
 

Author Comment

by:houston
ID: 1816270
helper

Thanks for your input and advice.  You and the other folks here are really great.

houston
0
 

Author Comment

by:houston
ID: 1816271
jpk

Turns out Microsoft now has a fix for the MTU problem.  I got it and installed it.

I thought substituting Trumpet was a good idea so, I downloaded and installed it.  I couldn't get it to connect to the provider because I don't know what the logon protocol is [I use the DUN logon and don't know what it hands the provider.]

So, I tried to uninstall it.  It couldn't replace all the files it had deleted and it didn't remove itself completely. Now I'm having more serious problems.  If I ever get on long enough to post this it will be after many tries where the provider dumps me off.  Getting dumped off  is new after Trumpet installation/un?installation.  

0
 
LVL 6

Expert Comment

by:jpk041897
ID: 1816272
Sorry about that, all internet ISP's use PPP as DUN protocol

I Have a friend that used to use Trumpet extensivley, IIf you like I'll ask him to send me his login.cmd file and p9st it.
0
 

Author Comment

by:houston
ID: 1816273
It's PPP, that's not the question.  The question is how/when it presents the username, password, and PPP instruction to the service.  My service does not present prompts for these so apparently it expects them to be automatically sent some way and possibly encrypted?????????

I think I've gotten things back where I was before Trumpet.

That was a good idea if I could have made Trumpet work.

The recovery made me discover I can't remove DUN so I can reinstall it.  I uncheck it in W95 setup, click OK and it reboots the machine but doesn't take it out.  The only way I know the setup works I have to remove it before I can reinstall it, and it won't remove.  I know this is not at the heart of the problem because it's new.  I have removed and reinstalled DUN several time attempting to trouble-shoot this problem.



0
 

Expert Comment

by:The Outsider
ID: 1816274
This same problem happened to me.  Try this, it involves editing your registry with REGEDIT.EXE found in your /WINDOWS directory.

 1. Go to HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/Class/NetTrans
 2. Under there will be folders like 0000 0001 0002, you need to find one that represents TCP/IP. Click on the FOLDER (not the +) and look to the right.  If you see a parameter "DriverDesc" with a "Data Value" of TCP/IP, that's the one.
 3. Go to the right panel and RIGHT click on any blank area and  select New->Stringvalueinue?
 4. Type MaxMTU, exactly as typed here (case sensitive).  Press return then double click on MaxMTU, a popup will appear.  Enter 576 for the value.
 5. Now add another one (see step 4).  Type MaxMSS, exactly as typed here (case sensitive).  Press return then double click on MaxMSS, a popup will appear.  Enter 536 for the value.
  6. Now you MUST reboot for the changes to take effect.

Happy surfing :)

0
 

Author Comment

by:houston
ID: 1816275
Is this the MTU optimization procedure suggested by jpk above and found at: http://www.sns-access.com/~netpro/maxmtu.htm#win95 ?

If so, there is now a Microsoft fix for this which I have installed.

In exploring your procedure I find I have 2 places which contain  "DriverDesc" with a "Data Value" of TCP/IP.   0000 is one and 0005 is the other.

Also when I right click on the place shown it does not provide an option named Stringvalueinue?  New has about 4 options but none are named Stringvalueinue.

0
 

Author Comment

by:houston
ID: 1816276
The MTU optimization did not stop/prevent/improve the problem so I am grading this F in order to reopen the question.  

Thanks for your interest and trying.

houston
0
 

Author Comment

by:houston
ID: 1816277
Edited text of question
0
 

Author Comment

by:houston
ID: 1816278
I have updated the question description by adding the following:

When this problem happens applications report a winsock error # 11004 which they variously describe as "NO DATA OF REQUESTED TYPE.  Couldn't resolve host name or address."  and "Host name not found."
0
 

Author Comment

by:houston
ID: 1816279
Edited text of question
0
 
LVL 2

Expert Comment

by:kolarb
ID: 1816280
0
 

Author Comment

by:houston
ID: 1816281
kolarb

I just got and installed the software, but I'm mailing in my modem for exchange so it won't have a chance to do its stuff 'til it comes back.  

I won't be following up here for probably a couple of weeks. I'll report in to say whether the modem fixed the problem.  

Thanks to everyone.  See you in a couple of weeks.

houston

0
 

Expert Comment

by:chieh061297
ID: 1816282
From the following, it sounds like you are having a DNS problem. Sometime you lost your link to it. I have it happen to me several times.

  "NO DATA OF REQUESTED TYPE. Couldn't resolve host
   name or address." and "Host name not found."

Try changing your domain name server (DNS)to another one. The internet is a mysterious network protocal, without any apparent reasons, you can loose packets through routers, gateways, and other systems. Some times during a sessions, I'd loose my DNS, or SMTP, or POP server. So far, I've moved from Los Angeles, to Kansas, and now, to Mississippi. Through out the years, I've changed number of servers, and stuck to ones I found most reliable. For example, I still connect to a server in California or Kansas to send mail. My uncle uses a local ISP and his SMTP went down one day, but was fixed in 5 minutes after I directed it to California. It takes experience, so if one server gives you the problem, try another one. Here are some tips that I found useful:

1. Any school's SMTP (send mail) server is more reliable than any commercial server. If not, the professors would raise hell with the System Administrator. (I was an Assistant System Administrator once)
2. Use a DNS as close to your network location as possible. As long as it does not go down often. Keeping the DNS close, gives you a faster connection to everywhere else. But if it crashes often, you won't get anywhere often. If you constantly get problem with one, try another one. It could be because of network collisons on a popular server, making you loose your packets.
3. If you loose your POP server, you're out of luck. Your e-mails are all on one server. Stick to one reliable to keep from becoming bald.

0
 

Author Comment

by:houston
ID: 1816283
Edited text of question
0
 

Author Comment

by:houston
ID: 1816284
chieh

I guess I don't find the suggestion satisfactory that I should keep switching ISP until I find one where this doesn't happen.  I have tried 3 and in happened on all 3.  On one I have used for 2 years I have a close friend who uses it more than I do and he never has the problem happen--while it happens to me about once every 2 hours of connect time.  I also know 5 others who use this ISP and never experience the problem.  These facts tell me the problem is not likely to be the provider.

Thanks for trying to help and please understand the F score isn't intended as a slam, it's just what I must do to open up the question again.

houston
0
 

Author Comment

by:houston
ID: 1816285
kolarb

I tried the Modem Wizard program.  It has a Check Internet connection function.  It reports no problems while I'm having the failure.  It beats me how it could think the internet is working properly when it isn't responding (sending anything) at all??????

Oh, well.  It was worth a try.  Thanks.

houston
0
 

Author Comment

by:houston
ID: 1816286
Edited text of question
0
 

Author Comment

by:houston
ID: 1816287
I have addeded a lot of new information to "The Question."
0
 

Expert Comment

by:chieh061297
ID: 1816288
Actually, I wasn't talking about changing ISP. I was talking about changing DNS. You can use any ISP with any DNS, and any SMTP, and any POP. You can use a local ISP and use a DNS all the way across the country, or even in another country. You just have to get the server address.
0
 
LVL 2

Accepted Solution

by:
e4monsch earned 200 total points
ID: 1816289
Reinstall your TCP/IP software, check your DNS configuration, your gateway, your subnet mask.

Regards Ian

0
 
LVL 2

Expert Comment

by:kolarb
ID: 1816290
Hi,

actually after I tried the Modem Wizard I was disappointed. It's not such a good program as advertised (well-I tried it after I recommended it to you).

But now I have been able to test another program that found some errors even on a superb internet connection. It's Net.Medic from vitalsigns.com It is really a great piece of software and I truly recommend it. Try it out, you'll be surprised. Even the folks at ZiffDavis IMag gave him high ratings and a BUY IT recommendation.

(I am not affiliated with any of the above mentioned companies - how could I be, I'm miles away from America)
0
 

Author Comment

by:houston
ID: 1816291
kolarb

I used the NetMedic program for my entire 1 month trial period.  I was using it when I posted this problem originally.  It showed a lot of internet and provider problems (mostly slowdowns) and some things that, best I can tell, weren't correct, but---it didn't help me understand why the provider end stops responding.  It would report that it was too slow when it wasn't responding at all.
It's an interesting program that displays a wealth of different things.  

By the way, the System Monitor program that comes with W95 can also be configured to show status of lots of things.

houston
0
 

Author Comment

by:houston
ID: 1816292
Thanks to all who tried to help with this problem.  

I never understood what is causing the problem but quit trying when I learned it didn't happen if I backed my modem DCE speed down to 24000bps.

It's a little slow but a lot better than the alternative.

houston
0
 

Author Comment

by:houston
ID: 1816293
To whomever is interested.  I still have this problem and therefore still use 24000bps for internet.

houston
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

It's here again; Microsoft is launching a new version of Internet Explorer: Internet Explorer 9, with noticeable changes on its interface, functions and new tools. As they say on its promotional video: "It's time to play, on a more beautiful web", f…
#Citrix #Internet Explorer #Enterprise Mode #IE 11 #IE 8
Google currently has a new report that is in beta and coming soon to Webmaster Tool accounts. This Micro Tutorial will highlight new features for Google Webmaster Tools.
How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now