Solved

Annon FTP Problem

Posted on 1997-05-23
4
223 Views
Last Modified: 2012-05-04
Anyone know how to fix a problem w/ annonymous FTP where it will not display any files?  I'm running Debian 1.2, and the wu-ftpd package.  I've been through the man pages and such, tried all their modes for the various directories, and still nothing.  If I log in as a normal user, everything works fine.  If I log in as "ftp", I get no display of files.  I can still "cd" and "put" and everything works, but I cannot
see anything.  Any suggestions?

I've been asked to add a little info... here it is.

I've created the ~ftp directory structure and added the user ftp to my system.  the user ftp currently has no password, and his shell is /bin/sh.  i've tried giving ownership of the ~ftp dir to root.root, ftp.root, ftp.ftp, and just about any other logical combination.  I've tried file permissions ranging from full access, to read/exec, to read, to exec for every file in the heirarchy including "bin/ls" in various combinations.  nothing works.

0
Comment
Question by:kgcurrie
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 1

Expert Comment

by:sherwood
ID: 1584710
wu-ftpd has good logging facilties.  Turn on logging,
and try again.

Could you be more specific.
1.  Add your present configuration file.
2.  What is the current permission of the ftp directory.
(ls -lR /whatever/ftp)

0
 

Author Comment

by:kgcurrie
ID: 1584711
Edited text of question
0
 
LVL 1

Expert Comment

by:sherwood
ID: 1584712
What is the content of your ftpaccess file? Do you have
ftpaccess enabled? (start the daemon with -a)

What kind of output do you get when ftpd is run with -d option?

Finally, have you put a copy of /bin/ls into /usr/local/ftp/bin
(or the bin directory underneath whatever your anon-ftp tree
starts at.

NOTE:  /bin/ls MUST be the statically linked form of hte command,
as anon ftp does a chroot to the ftp directory, which makes
the shared libraries that many programs use inaccessible.


0
 
LVL 2

Accepted Solution

by:
df020797 earned 50 total points
ID: 1584713
Check permissions as root in the ftp homecatalogue.

0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
The Email Laundry PDF encryption service allows companies to send confidential encrypted  emails to anybody. The PDF document can also contain attachments that are embedded in the encrypted PDF. The password is randomly generated by The Email Laundr…
Attackers love to prey on accounts that have privileges. Reducing privileged accounts and protecting privileged accounts therefore is paramount. Users, groups, and service accounts need to be protected to help protect the entire Active Directory …

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question