Solved

Warcraft II crashes

Posted on 1997-05-24
20
1,790 Views
Last Modified: 2011-09-20
When I try to play warcraft under windows95 in the setup screens before the game ie single player or multiplayer after a few minutes the mouse just freezes and I have to reboot under dos sometimes I get a dos/4gw error such as:
DOS/4GW Professional error (2001): exception 0Eh (page fault) at 268:100DCFFR
TSF32:prev_tsf32 6B0C
ss      270      DS      270      ES      270FS      06S      20
GGDOS/4GW Professional error (2000) : deinitializing twice
DOS/4GW Professional error (2000): deinitializing twice

What's wrong? The game once worked fine on my computer but after I reformatted my harddrive and reinstalled everything including warcraft, these things started happening.
0
Comment
Question by:ayoung
  • 7
  • 6
  • 2
  • +5
20 Comments
 
LVL 2

Expert Comment

by:allways
ID: 1106361
try to disable the "autostart" on the cd-rom .
put in the cdrom hold down "shift"
0
 
LVL 2

Expert Comment

by:allways
ID: 1106362
try another sound card ?
0
 

Author Comment

by:ayoung
ID: 1106363
I don't have another sound card to try and It doesn't even work when I turn off the sound card anyways. The autostart has nothing to do with my problem
0
 

Expert Comment

by:griver
ID: 1106364
As far as the lock up in Win 95, it sounds like there is a Hardware conflict!

You said you reformatted your HD and re-installed everything!?

Have you changed anything at all or not installed everthing as before? ie: different Video Drivers or mouse drivers?

Also, what caused you to re-formatt your HD?


0
 

Author Comment

by:ayoung
ID: 1106365
Wierd things were happening so I decided to Startover. I don't think I missed anything and as far as drivers are concerned I have installed all of the latest. I don't think there's a hardware confilict because windows95 doesn't dectect one.
0
 

Expert Comment

by:griver
ID: 1106366
Ok!

What type of Souncard and Video Card do you have and What version mouse driver do you have!

Also, try making a bootdisk that loads ONLY your mouse, sound and cdrom drivers and try the game!
0
 

Author Comment

by:ayoung
ID: 1106367
my sound card is:
Creative Labs Sound Blaster 16 or AWE 32
My video card is:
ATI GRAPHICS XPRESSION (DirectDraw)
My mouse driver is ver 8.0
I tried the boot disk loading only cd Rom and mouse and it doesn't help infact I am getting a DOS/4GW error in dos now before the game even starts
0
 

Expert Comment

by:griver
ID: 1106368
First try running SETUP and set DIGITAL sound for soundblaster not SB16!

Also you should be using Mouse driver VER 8.2
You can get it at  http://www.blizzard.com/bin/MOUSE.ZIP

You can also try editing your WAR2.INI and ensure CDAUDIO=0

My bet is the mouse!
0
 

Expert Comment

by:griver
ID: 1106369
There is also a patch that adds more sound support and fixes various other bugs!

You can get it at  http://www.blizzard.com/bin/W2PATCH.EXE
0
 

Author Comment

by:ayoung
ID: 1106370
I am sorry I made a mistake I do have ver 8.2 mouse
I have tried with all the sound off and no luck.
If I have all of the sound set to no sound could the sound card still be causing a conflict?
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 

Author Comment

by:ayoung
ID: 1106371
I have the w2patch
0
 

Expert Comment

by:griver
ID: 1106372
Not likely! When all sound is turned off the game never looks for the card!

Lets make sure I got this right

You have tried the game both in WINDOWS and in DOS?

WHen you ran it in DOS did you just run the game so it shelled to DOS or did you BOOT to DOS?
0
 

Author Comment

by:ayoung
ID: 1106373
yes I tried the game in windows and in dos( boot to dos)  when I run it it in windows 1 of two things occurs
1. The mouse will frezze during the startup screens before the game i.e. sigle player or multiplayer
2. If I go fast enough I get to play the game but after about 5 - 15 minutes into the game I get a dos/4gw error

In dos I can't get the game to start at all right now. All i get is a dos/4gw befor the game even starts.
0
 

Expert Comment

by:griver
ID: 1106374
When you boot to Dos make sure your mouse driver is loading!
Just checking all Avenues here!

Lets eliminate the Soundcard as the problem,
Turn off the system and remove the card and then try running the game with ALL sound disabled!

Also, have you had any problem with any other games that utilize the same game engine! Or have you not tried any others?

If you want you can e-mail me at griver@earthlink.net if it's easier for ya!
0
 

Expert Comment

by:Voxol
ID: 1106375
Try copying Dos/4gw from another game or of the CD perhaps
0
 
LVL 1

Expert Comment

by:foxeye
ID: 1106376
I had the same problem once. I figured it was some problem with my sound card ( Sound blaster 16 ) cause when I disabled the sound it worked perfectly. Never got to know what the problem was though. Try buying another sound card :-) No just kidding, try disabling the sound and see if it works, at least then you have located the source of the problem.
0
 

Expert Comment

by:zeper
ID: 1106377
Run the game on a MS-DOS PC and it will work, WIndows 95 is ****.

Greetings ZEPER
0
 

Author Comment

by:ayoung
ID: 1106378
That was the most useless comment I've ever recieved!
0
 

Expert Comment

by:tony.d
ID: 1106379
Be sure to check all of your irq settings.  Especially the ones for the mouse, the hard drive, and the sound card.
0
 
LVL 2

Accepted Solution

by:
ChrisK earned 100 total points
ID: 1106380
Zepers answer is correct, but I'll be a bit more helpfull with my answer...  You need to make sure you have the DOS mouse driver, sound driver, and video driver loaded FROM DOS, as in the config.sys and autoexec.bat and make sure you have about 600k free for conventional memory plus all the ems you are able to get free'd up.  Use this EMM line to help...

device=c:\dos\emm386.exe i=b000-b7ff

And like it or not, DOS never fails, windows is worthless.
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

For those of you searching for a fun but also medium paced MMORPG game I would highly suggest Ragnarok Online. This MMORPG is a bit older than World of Warcraft and in a way is extremely different. Compared to WoW's 3D environment and massive wor…
As we all know Counter Strike is a very popular computer game. Usually it is played over a network for which people create a server and users join it but it is interesting to know that one can creates a dedicated server which not only hosts the game…
Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now