Modem not responding

Hello,


OS Red Hat 4.1
MB Intel Marl
USR Sporster 28.8 v.34 Internal Fax Modem (not Winmodem).
COM4 UART 16550 0x02e8 IRQ 3


In both Minicom and Seyon, the modem doesn't respond. Why?

This is whatI have done.  What am I missing

1. I have read the setserial HOWTO
2. I have tried linking the modem to cua0-3 to the modem.
3. I have tried linking the modem to ttys0-3 to the modem.
4. I have configured the ports with setserial.
5. I turned off the PNP in the bios. (just fot the hell of it)
6. I configured Minicom with my settings.

When reconfiguration Minicom or any of the files I am login as root.

I don't know my modem works great under Win 95.  Please
help me out on this one.  
TuckAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TuckAuthor Commented:
If anyone reading this has had the same problem and fixed it, please drop me aline.  Thanks!  Thanks for Expert Exchange also.                            Tuck
0
smattesoCommented:
I went through your dilemma and might have an answer for you.
My modem is on comm3 (or cua2) however.
I'm assuming you have a dual boot situation and you're using the
exact same modem for both Win95 and Linux operating systems.

First, look at your Win95 configurations for your modem in
device manager.  Make sure of the comm port and the IRQ
and IO setting as Win95 recognizes it.  If your modem is really
on comm4, you must make sure this doesn't conflict with your
mouse on Comm2 or something.  Comm2 and Comm4 share the same IRQs
unless you make them different.  Just because they don't
conflict in Win95, doesn't mean they won't conflict in Linux.
Linux demands more out of it's hardware, so the whole setup
is usually less forgiving.If at all possible, use comm3 since I think I remember reading somewhere that Linux was flakey
with comm4 (I don't have the reference, but possibly you could
check it out).

Once you write these modem setting down from Win95, restart
computer and boot Linux (make sure your bios is ENABLED).
 
Check to see if your comm ports show up at bootup.  If you
missed the bootup messages, just type

dmesg |more

at root prompt.

If they do, then type these two lines (for comm port 3).

setserial /dev/modem auto_irq  
(or setserial /dev/cua2 auto_irq)

setserial /dev/modem auto_config
(or setserial /dev/cua2 autoconfig)

(make sure you have linked /dev/modem to the modem device
such as /dev/cua2 for comm3 if you specify /dev/modem)

These commands should search and configure your modem
automatically.

I believe if you say
setserial /dev/modem

it will tell you the new IRQ setting and comm address that
Linux recognizes the modem at.
These will most likely match what they are configured as in
Win95.

If this doesn't help, there is also a utility for Linux to
recoginize those "hard to recognize" plug-and-play devices
called something like pnptools for Linux or something.
I didn't need to use this to solve my problem, though, so
you most likely won't have to either.
Let me know if this helps,

Stephen Matteson
smatteso@silcom.com





0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.