Compiling Q

I am using SlackWare 3.2 With Kernel 2.0.29. When i try the
new zImage file after compiling the kernel i get a whole
lot of Unresolved symbols in Module xx.x messages. The rest
of the bootup works and i can use Linux afterwards.

What a i doing wrong? please help.
Fran032697Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jprohartCommented:
if you have compiled a new kernel, the version of the modules may be not the same than the kernel. Do 'uname -r' to see the kernel version, and look at '/lib/modules/2.0.xx/' (where 2.0.xx is your version) to see if you compiled the modules. In case you included all in the kernel, edit the file /etc/conf.modules (of if you use RedHat run kernelcfg under X) to see if they are lines in it (in this case remove all unnecessary lines). If you don't want modules, you can recompile without the option 'autoload of modules' . If you want modules, make menuconfig in /usr/src/linux and declare the modules (again look at /etc/conf.modules), then do 'make dep; make clean ; make modules ; make modules_install'.
hope this help.
Bye

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Fran032697Author Commented:
I had to remove the existing modules directory, and there is no
conf.modules or modules.conf files anywhere to bee seen.
0
Fran032697Author Commented:
At long last i figured out the answer. There was a lot of stale
rc files in /etc/rc.d and i had to remove them.
0
Fran032697Author Commented:
At long last i figured out the answer. There was a lot of stale
rc files in /etc/rc.d and i had to remove them.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.