out of server storage space

can anyone suggest a solution for this message recieved
when the win nt server service tries to start:

error 1130: not enough server storage is available to process this command.

what is server storage and what can i do to set this.
i am presuming that this is not related to physical disk space, as i have a sufficient amount for any function.

I have 2 pagefiles set on drives D: and C: (winnt is on e:)
The size of the pagefile on both of these drives is
set to 75 - 200 so there should be more than enough memory.
I also have 96Mb of RAM.

thanks
           Luke.

 
luke kAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

brauner071697Commented:
It is possible that yout server run out of Memory.
Look at your pagefile at turns it on ca. 20 MB of your RAM.
e.g.
64 MB RAM
Pagefile 80- 95 MB

regards

Gerd
0
luke kAuthor Commented:
Edited text of question
0
luke kAuthor Commented:
I have 2 pagefiles set on drives D: and C: (winnt is on e:)
The size of the pagefile on both of these drives is
set to 75 - 200 so there should be more than enough memory.
I also have 96Mb of RAM.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

brauner071697Commented:
decrease your upper limit to 100 MB
0
luke kAuthor Commented:
no change :(
0
brauner071697Commented:
Hy luke,

found it somewhere:

When you access shares on a Windows NT server from a Windows NT client and the IRPstackSize parameter is set too low on the server, you may receive the following error message:

Not enough server storage is available to process this command.

The registry value IRPstackSize, which may be listed at
HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ LanmanServer\Parameters defaults to 0x4 if the value is not explicitly present.
Valid values range from 0x1 to 0xC (1 to 12). Depending on the
hardware configuration of a specific machine, the default value may not be large enough for the Srv service to properly administer shared directories on some of the physical drives. When this is the case, the Event Log on the server in question will contain the following event message:

   Event ID: 2011  Source: Srv
   The server's configuration parameter "irpstacksize" is too       small for the server to use a local device.  Please increase     the value of this parameter.

You may receive the above error message when a Windows NT client tries to access certain shared directories on such a server.

When a Windows for Workgroups client tries to access the same shared directories, the following message will be generated:
   Path not found.

To increase the value of the parameter when it is not already present, drill down to the HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\Services\ LanmanServer\ Parameters key in the Registry Editor and choose Add Value from the Edit menu. The Value Name should be IRPstackSize and the Data Type is REG_DWORD.


0
luke kAuthor Commented:
Hello,

In the directory you specify above in the registy there is
a value called 'Size: REG_DWORD 0x1' and as you said
 added the value 'IRPstackSIze: REG_DWORD 0x4' that
seemed to be ok but are these 2 one in the same?
I changed the value for IRPstackSize from 0x1 up to 0x12
but the error still occurred. The 'Size' value could
only be changed to 0x1 and 0x2 and that was all, all other values
gave an error in the event viewer.

Is what I did right? Obviously not because i didn't work...

Thanks,

Melinda
0
RincewindCommented:
If you receive this error, you may have a non-zero PagedPoolSize entry in the registry. Edit:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

Set PagedPoolSize to 0.

Reboot.
0
luke kAuthor Commented:
Our problem was solved by installing
and overwritting all  newer files.
I assume that they were residual from service pack 3.
Thank you for all your help.

Luke.
0
handrichCommented:
Hi

I have the same problem and think that only reinstalling (upgradeing) helps.

Michael
0
DuboisPCommented:
Microsoft Knowledge Base

Err Msg Using NET USE: System Error 1130 Has Occurred

Last reviewed: September 23, 1996
Article ID: Q124357 The information in this article applies to:

•Microsoft Windows NT Server version 3.5







SYMPTOMS

When you use the NET USE command to connect to computer running Windows NT, the following error message appears:



   System Error 1130 has occurred.
   Not enough server storage is available to process this command.




In some cases the following text is written to the Event Viewer system log:



   The server was unable to perform an operation due to a shortage of
   available resources.

      0000: 000c0000 005c0001 00000000 c00007d1
      0010: 00000000 c000009a 00000000 00000000
      0020: 00000000 00000000 000007d2 0000000b
      0030: 0000003c






RESOLUTION

To correct this problem:

WARNING: Using Registry Editor incorrectly can cause serious, system-wide problems that may require you to reinstall Windows NT to correct them. Microsoft cannot guarantee that any problems resulting from the use of Registry Editor can be solved. Use this tool at your own risk.



1.Run Registry Editor (REGEDT32.EXE).

2.From the HKEY_LOCAL_MACHINE subtree, go to the following key:





      \SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters





3.From the Edit menu, choose Add Value.

4.Use the following values:





      Value Name: MinFreeConnections
      Data Type:  REG_DWORD

      Decimal:     5






5.Close Registry Editor.

6.Run Control Panel and choose Network.

7.Under Installed Network Software, highlight Server and then choose Configure.

8.Under Optimization, select Maximize Throughput for File Sharing and then choose OK.

9.Either shutdown and restart Windows NT, or from a command prompt, type the following two commands (pressing ENTER after each line):





      net stop server
      net start server
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.