Reducing number of ramdisk?

I installed Redhat 4.1 on a computer with 64meg of memory and now want to reduce that to 16meg of memory.  Taking out the simm's caused a ramdisk error at boot.  I have the original kernel with no problems until now.  With 64meg installed at boot it creates (16) 4meg ramdisk.  (16x4meg=64meg).  This works fine with no problems.  When I have only 16meg in the machine it tries to do the same thing and errors out.  I've tried mem=16 at the LILO: and this did not solve the problem. The line in the dmesg log is:Ramdisk driver initialized : 16 ramdisk of 4096K sizeThis works fine with 64meg, but it still tries to create 16 when it only has 16meg of ram.  What I would expect is that it would create 4 ramdisk of 4096K size.erich@jjt.com
erichAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

drzCommented:
The real solution is to recompile the kernel with Initial RAM disk support disabled. Besides for installations RAM disks have no real use anyway. Memory not used for a RAM disk will instead automatically be used to cache data that is accessed the most.
Alternatively, you could pass ramdisk_size=1 (for 1Kb) at the LILO prompt, and it should boot without problems.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
erichAuthor Commented:
Any tips on what I need to look for or set to disable the Initial RAM disk when I recompile the kernel.
0
drzCommented:
Disabling CONFIG_BLK_DEV_INITRD should do it. Otherwise, you could always disable RAM disks altogether. CONFIG_BLK_DEV_RAM is they keyword that does that.

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.